1. 首页
  2. 金融百科

彩色K线 简洁美观简约而不简单 (主图 通达信源码 有未来)

VAR1:=LLV(L,10);
VAr2:=HHV(H,25);
趋势:=ema((C-VAR1)/(VAR2-VAR1),10);
AA:=趋势=REF(趋势,1);
BB:=趋势REF(趋势,1);
买入:DRAWicoN(croSS(AA,BB),L-0.1,23);
卖出:DRAWICON(CROSS(BB,AA),H 0.1,15);
{红}
stICKline(AA,C,OPEN,3.5,0),COLOR0000BB;
stiCKLINE(AA,C,OPEN,2.5,0),COLOR0000CC;
STICKLINE(AA,C,OPEN,0.8,0),COLOR0000FF;
STICKLINE(AA,C,OPEN,0.1,0),COLORCc66FF;
{青}
STICKLINE(BB,C,OPEN,3.5,0),COLOR009900;
STICKLINE(BB,C,OPEN,2.5,0),COLOR00BB00;
STICKLINE(BB,C,OPEN,1.5,0),COLOR00DD00;
STICKLINE(BB,C,OPEN,0.5,0),COLOR00FF00;
STICKLINE(BB,C,OPEN,0.1,0),COLORCYAN;
{金黄色立柱}
STICKLINE(买入,O,(C-O)/2 O,3.8,0),COLOR337777;
STICKLINE(买入,O,(C-O)/2 O,2.5,0),COLOR339999;
STICKLINE(买入,O,(C-O)/2 O,1.5,0),COLOR33aaaA;
STICKLINE(买入,O,(C-O)/2 O,1,0),COLOR33cccc;
STICKLINE(买入,O,(C-O)/2 O,0,0),COLOR33EEEE;
{粉红立柱}
STICKLINE(卖出,O,(C-O)/2 O,3.5,0),COLOR770077;
STICKLINE(卖出,O,(C-O)/2 O,2.5,0),COLOR990099;
STICKLINE(卖出,O,(C-O)/2 O,1.5,0),COLORBB00BB;
STICKLINE(卖出,O,(C-O)/2 O,1,0),COLORDD00DD;
STICKLINE(卖出,O,(C-O)/2 O,0.1,0),COLORFF00FF;
MA5:MA(C,5),COLORWHITE,LINETHICK1;
ma10:MA(C,10),COLOR00FFFF,LINETHICK1;
Ma21:MA(C,21),COLORC0FF7F,LINETHICK1;
Ma60:MA(C,60),COLORFF00FF,LINETHICK1;
{老鼠仓}
AX:=AMOUNT/V;BX:=LAX*0.9; CX:=(C-REF(C,1))/REF(C,1)*1001.2;
DZ:=LMA(C,5)*0.921;EX:=VMA(V,5)*1.5;
老鼠仓:=BX AND CX AND DZ AND EX,LINETHICK0;
DRAWTEXT(老鼠仓,(L*0.99),'↖老鼠仓'),COLOR40CCFF;
RA:=zig(3,10);
GG:=MA(RA,2);
DRAWICON(CROSS(GG,RA),H 0.1,15);
DRAWTEXT(CROSS(RA,GG),L*0.99,'↖买'),COLOR00FF00;
{涨跌停提示}
ZDF:=(C-REF(C,1))/REF(C,1)*100;
DRAWTEXT(C=1.099*REF(C,1),C*1.01,'↙涨停'),COLORYELLOW;
DRAWTEXT(ZDF-9.9,C*1.01,'↖跌停'),COLOR00FF00;
获利%:winner(C)*100,NodRAW,COLORFF00FF;
涨家数:INDEXADV,COLOR0000EE,NODRAW;
跌家数:INDExdEC,COLOR00EE00,NODRAW; 大盘成交量:INDEXV,COLOR00EEEE,NODRAW;
上市日期年:REF(YEAR,BARSCOUNT(C)-1),NODRAW,COLOR0000FF;
月:REF(MONTH,BARSCOUNT(C)-1),NODRAW,COLORFF00FF;
日:REF(DAY,BARSCOUNT(C)-1),NODRAW,COLOR00FFFF;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.denguang.com/baike/8d869ba9168c5a671b3dbe21.html

标签: