蜀ICP备16033882号-3

  1. 首页
  2. 金融百科

捕捉强势涨停股票(大智慧源码)

掌握各种盘中强势股票的走势特征,然后综合评分,选出符合条件最多的股票,一般都是强势个股,而且容易涨停。最好做成排序,强势个股一目了然。
INPUT:N(1,1,60),主力资金趋势(1,1,30),N1(6,2,100),M1(2,2,50),M2(2,2,50);
RSV:=(close-LLV(LOW,N1))/(HHV(high,N1)-LLV(LOW,N1))*100;
流通盘A:=CAPITal/1000000;

三日大涨幅:=(c-ref(c,3))/ref(c,3)*10023;
两日大涨幅:= (c-ref(c,2))/ref(c,2)*10018;
单日大涨幅:=(c-ref(c,1))/ref(c,1)*1009.9;
三日强无大跌:= (hhv(c,12)-c)/c*10013;
两日强无大跌:= (hhv(c,8)-c)/c*1008;
单日强无大跌:= (hhv(c,3)-c)/c*1004;
强势股:=if(dynainfo(4)0,(any(三日大涨幅,9) and 三日强无大跌)
or (any(两日大涨幅,6) and 两日强无大跌)
or (any(单日大涨幅,3) and 单日强无大跌),0);

{单数比}
ddx:(BIGORDER(1)-BIGORDER(2))*VOL/CAPITAL*100,linethick0;
净成交:Ddx*V/100000,COLOR3D;
TODAY:=ddx.ddx=0;{判断是否有正版数据}
TODAY1:=DYNAINFO(7)=CLOSE and DYNAINFO(10)=AMOUNT AND TIME055800;{判断是否有理想数据}
{条件}
买入单:=IF(TODAY,IF(TODAY1,ddedata@ORDER(1),SELfdaTA('买入单数')),ORDER(1));
卖出单:=IF(TODAY,IF(TODAY1,DDEDATA@ORDER(2),SELFDATA('卖出单数')),ORDER(2));
{计算}
买入单数:=买入单;
卖出单数:=卖出单;
{计算}
单数差:=卖出单数-买入单数;
买比:=买入单数/(买入单数 卖出单数);{买入单数占买卖总单数比值}
卖比:=卖出单数/(买入单数 卖出单数);{卖出单数占买卖总单数比值}
单比净:=卖比-买比;


a:=ma(close,3);
角度:=atan((a/ref(a,1)-1)*100)*180/3.1416;
ddd:=IF(BARSLAst(croSS(MA(C,20),MA(C,5)))-BARSlast(CROSS(MA(C,5),MA(C,20)))0,BARSLAST(CROSS(MA(C,20),MA(C,5)))-BARSLAST(CROSS(MA(C,5),MA(C,20))),0);
交易分钟数:=if(CUrrENTTIME93000 and CURRENTTIME150000,if(CURRENTTIME113000 ,(TIMETOT0(CURRENTTIME)-34200)/60,if(CURRENTTIME130000 , (TIMETOT0(CURRENTTIME)-39600)/60,120)),240);
预测成交:=v/交易分钟数*240;
QKF:=KD,KD;
QKG:=macD,DIFFDIF;
b1:=vol/ref(vol,1);
b2:=b11 and b11.6;
c1:=ma(vol,5)/capital0.05;
10,COLORYELLOW;
评分:IF(强势股=1,2,0) if(净成交0,1,0) IF(MA(C,5)REF(MA(C,5),1),1,0) if(macd.diff(6,9,3)REF(macd.dIFF(6,9,3),1),1,0) if(kdj.J(9,3,3)REF(kdj.J(9,3,3),1),1,0) IF(NOT(预测成交=HHV(VOL,34)),1,0) IF(角度45,1,0) IF(流通盘A8,1,0) if(单比净0,1,0) IF(count(closeOPEN,9)/90.5,1,0) IF(COUNT(CO AND V/MA(V,10)1.2,14)2,1,0) IF((COUNT(IF(CO AND VMA(V,10),1,0),9)=(COUNT(CO,9)-1)),1,0) IF(count(b2,7)/70.6 and c1,1,0),COLORRED;

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.denguang.com/baike/e50b0a8e16004714689eecfb.html

标签:

标签: