1. 首页
  2. 灯光观点

通达信AI金融机构主图指标公式



C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2=(10-0.01*100/C2),1,0);
stICKLINE(涨停,OPEN,close,2,0),COLOrrED;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
圣:=(HHV(high,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
灵:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
石:=sma(灵,13,8);
仙:=CEILING(SMA(石,13,8));
编著:=SMA(圣,21,8);
AABB:=IF(L,const(L),DRAWNULL);
启动:STICKLINE(仙-编著75,AABB,AABB*0.99,15,1),COLOR0000FF;
{VARZT:=BARSLAST(平台启动);}
{DRAWTEXT(VARZT=1,0.99*(AABB AABB*0.98)/2,平台启动),COLORYELLOW;}
AAA:=(3*C H L O)/6;
VAR1:=(8*AAA 7*REF(AAA,1) 6*REF(AAA,2) 5*REF(AAA,3) 4*REF(AAA,4) 3*REF(AAA,5) 2*REF(AAA,6) REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5) HHV(VAR1,10) HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5) LLV(VAR1,10) LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5) HHV(VAR2,10) HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5) LLV(VAR3,10) LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2) LLV(VAR1,4) LLV(VAR1,6))/3;
DRAWBAND(VAR1,rgb(155,50,50),VAR6,RGB(250,250,0));
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;
TJ1:=VOL=HHV(VOL,10) AND VOL2*REF(VOL,1) AND CLOSEVAR1;
立桩量:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSEREF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSEREF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSEREF(HIGH,3),1,0)));
突破:=TJ2=1;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(立桩量)),REF(HIGH,BARSLAST(立桩量)),1,0),COLORCYAN;
STICKLINE(CLOSE,REF(LOW,BARSLAST(立桩量)),REF(LOW,BARSLAST(立桩量)),1,0),COLORYELLOW;
TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSEREF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSEREF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSEREF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWTEXT(条件成立,L*0.99,成立),COLORYELLOW;
STICKLINE(C=O,C,O,3,0),COLOR000045;
STICKLINE(C=O,C,O,2.5,0),COLOR000065;
STICKLINE(C=O,C,O,2,0),COLOR000085;
STICKLINE(C=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C=O,C,O,1,0),COLOR0000C5;
STICKLINE(C=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C=O,H,L,0,0),COLOR0000F5;
STICKLINE(CO,C,O,3,0),COLOR353500;
STICKLINE(CO,C,O,2.5,0),COLOR454500;
STICKLINE(CO,C,O,2,0),COLOR555500;
STICKLINE(CO,C,O,1.5,0),COLOR656500;
STICKLINE(CO,C,O,1,0),COLOR757500;
STICKLINE(CO,C,O,0.5,0),COLOR858500;
STICKLINE(CO,H,L,0,0),COLOR959500;
HIGHN:=10;
LOWN:=10;
HIGHDISPLAY:=0;
LOWDISPLAY:=0;
ZGDISPLAY:=0;
MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN 1);
QY:=BACKSET(AA,HIGHN 1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN 1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD 1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD 1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD 1);
MM:=IF(CURRBARSCOUNTGDCS2,0,1);
上轨:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORBLUE,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN 1);
QY1:=BACKSET(AA1,LOWN 1);
Cc1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN 1);
DRAWICON(CC1,L*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1 1);
DDTS2:=REF(DDTS1,DD1 1);
DDCS2:=CONST(DDTS2);
下轨:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK1;
ZGSTAR:=(上轨 下轨)/2;
ZGEND:=CONST((上轨 下轨)/2);
STARDAY:=IF(DDCS2GDCS2,DDCS2,GDCS2);
中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT;
DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGHLOW 0.04,4,0);
VAR11:=zig(3,6)REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)=REF(ZIG(3,72),3);
VAR19:=ema(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11 VAR13 VAR15 VAR17);
卖1:=(VAR12 VAR14 VAR16 VAR18);
B:IF(买10 OR 买20,LOW*0.99,DRAWNULL),croSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买10 OR 买20,LOW*0.99,买),COLORRED;
S:IF(卖10,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖10,HIGH*1.02,卖),COLORGREEN;
DRAWICON((ZIG(3,5)REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)=REF(ZIG(3,5),3)),LOW*0.98,1) ;
DRAWICON((ZIG(3,5)REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)=REF(ZIG(3,5),3)),HIGH*1.01,2);
ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;
VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
K:=EMA(VAR7,5)*2, , COLORFF00FF;
D:=EMA(K,5), , COLORWHITE;
J:=K*3-D*2, ,COLORYELLOW;
VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J10;
HS:=VOL/CAPITAL*100, , COLORGREEN;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1) 2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,机构进场),LINETHICK1,COLORFF00FF;
VAR1A:=IF(VARE0,VARE,0);
VAR1B:=IF(VAR14=200 AND VAR13=150,15,IF(VAR14=-200 AND VAR13=-150,-15,VAR16)) 60;
VAR1C:=VAR1A48 AND VAR1B60 AND VAR19100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,大顶(底)) COLORWHITE;
指标王:=CROSS(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),SMA(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),3,1)) AND SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1)20;
DRAWTEXT(指标王,L,主力建仓),COLORYELLOW;
DRAWTEXT(VAR1,L*0.98,★短买),COLORYELLOW;
DRAWTEXT(CROSS(MA(C,3),MA(C,9)) AND C=REF(C,1) AND CO,L*0.98,),COLORMAGENTA;
下降压力线:DRAWLINE(HIGH=HHV(HIGH,10),HIGH,LOW=LLV(LOW,3),HHV(HIGH,3),1),LINETHICK2;
STICKLINE(CURRBARSCOUNT=2,L,L,10,0),COLORGREEN,;
DRAWNUMBER(ISLASTBAR,REF(L,1),REF(L,1));

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.denguang.com/guandian/2e3563220099c251d96cc5e3.html

标签: