蜀ICP备16033882号-3

  1. 首页
  2. 软件书籍

板块动态 精进简约版{副图 源码}

股票软件说明:

{简睿板块动态 - 理想论坛 壹瓣杺埖 }
{N 1 99 9; M1 1 99 3; M2 1 99 3;}
CUrr:=CURRBARSCOUNT;
stICKline(1=1,15,-5,18,0),COLOR878787;
DRAWTEXT(CURR=73,13,'理想论坛 壹瓣杺埖 '),COLOR8E0000;
上证量比:=const(999999$VOL/REF(MA(999999$VOL,5),1)*10);
深证量比:=COnsT(399001$VOL/REF(MA(399001$VOL,5),1)*10);
量比:STICKLINE(1=1,IF(CURR=55,上证量比*1.05,IF(CURR=20,深证量比*1.05,DRAWNULL)),0,39,-1),COLOR66CCFF;
STICKLINE(1=1,IF(CURR=55,上证量比,IF(CURR=20,深证量比,DRAWNULL)),0,38,0),COLOR0088FF;
大盘股量比:=CONST(399372$VOL/REF(MA(399372$VOL,5),1)*10);
大盘C:=(399372$C); 大盘H:=(399372$H); 大盘L:=(399372$L); 大盘O:=(399372$O);
大盘股涨跌:=CONST(((大盘C-REF(大盘C,1))/REF(大盘C,1))*200);
大盘偏差:=(2*大盘C 大盘H 大盘L 大盘O)/5-(MA(大盘C,3) MA(大盘C,6) MA(大盘C,12) MA(大盘C,24))/4;
大盘R:=(大盘偏差-LLV(大盘偏差,N))/(HHV(大盘偏差,N)-LLV(大盘偏差,N))*10;
大盘K:=sma(大盘R,M1,1); 大盘D:=SMA(大盘K,M2,1); 大盘股0:=3*大盘K-2*大盘D;
大盘股J:=CONST(大盘股0);
中盘股量比:=CONST(399374$VOL/REF(MA(399374$VOL,5),1)*10);
中盘C:=(399374$C); 中盘H:=(399374$H); 中盘L:=(399374$L); 中盘O:=(399374$O);
中盘股涨跌:=CONST(((中盘C-REF(中盘C,1))/REF(中盘C,1))*200);
中盘偏差:=(2*中盘C 中盘H 中盘L 中盘O)/5-(MA(中盘C,3) MA(中盘C,6) MA(中盘C,12) MA(中盘C,24))/4;
中盘R:=(中盘偏差-LLV(中盘偏差,N))/(HHV(中盘偏差,N)-LLV(中盘偏差,N))*10;
中盘K:=SMA(中盘R,M1,1); 中盘D:=SMA(中盘K,M2,1); 中盘股0:=3*中盘K-2*中盘D;
中盘股J:=CONST(中盘股0);
小盘股量比:=CONST(399376$VOL/REF(MA(399376$VOL,5),1)*10);
小盘C:=(399376$C); 小盘H:=(399376$H); 小盘L:=(399376$L); 小盘O:=(399376$O);
小盘股涨跌:=CONST(((小盘C-REF(小盘C,1))/REF(小盘C,1))*200);
小盘偏差:=(2*小盘C 小盘H 小盘L 小盘O)/5-(MA(小盘C,3) MA(小盘C,6) MA(小盘C,12) MA(小盘C,24))/4;
小盘R:=(小盘偏差-LLV(小盘偏差,N))/(HHV(小盘偏差,N)-LLV(小盘偏差,N))*10;
小盘K:=SMA(小盘R,M1,1); 小盘D:=SMA(小盘K,M2,1); 小盘股0:=3*小盘K-2*小盘D;
小盘股J:=CONST(小盘股0);
农林量比:=CONST(399110$VOL/REF(MA(399110$VOL,5),1)*10);
农林C:=(399110$C); 农林H:=(399110$H); 农林L:=(399110$L); 农林O:=(399110$O);
农林涨跌:=CONST(((农林C-REF(农林C,1))/REF(农林C,1))*200);
农林偏差:=(2*农林C 农林H 农林L 农林O)/5-(MA(农林C,3) MA(农林C,6) MA(农林C,12) MA(农林C,24))/4;
农林R:=(农林偏差-LLV(农林偏差,N))/(HHV(农林偏差,N)-LLV(农林偏差,N))*10;
农林K:=SMA(农林R,M1,1); 农林D:=SMA(农林K,M2,1); 农林0:=3*农林K-2*农林D;
农林J:=CONST(农林0);
采掘量比:=CONST(399120$VOL/REF(MA(399120$VOL,5),1)*10);
采掘C:=(399120$C); 采掘H:=(399120$H); 采掘L:=(399120$L); 采掘O:=(399120$O);
采掘涨跌:=CONST(((采掘C-REF(采掘C,1))/REF(采掘C,1))*200);
采掘偏差:=(2*采掘C 采掘H 采掘L 采掘O)/5-(MA(采掘C,3) MA(采掘C,6) MA(采掘C,12) MA(采掘C,24))/4;
采掘R:=(采掘偏差-LLV(采掘偏差,N))/(HHV(采掘偏差,N)-LLV(采掘偏差,N))*10;
采掘K:=SMA(采掘R,M1,1); 采掘D:=SMA(采掘K,M2,1); 采掘0:=3*采掘K-2*采掘D;
采掘J:=CONST(采掘0);
制造量比:=CONST(399130$VOL/REF(MA(399130$VOL,5),1)*10);
制造C:=(399130$C); 制造H:=(399130$H); 制造L:=(399130$L); 制造O:=(399130$O);
制造涨跌:=CONST(((制造C-REF(制造C,1))/REF(制造C,1))*200);
制造偏差:=(2*制造C 制造H 制造L 制造O)/5-(MA(制造C,3) MA(制造C,6) MA(制造C,12) MA(制造C,24))/4;
制造R:=(制造偏差-LLV(制造偏差,N))/(HHV(制造偏差,N)-LLV(制造偏差,N))*10;
制造K:=SMA(制造R,M1,1); 制造D:=SMA(制造K,M2,1); 制造0:=3*制造K-2*制造D;
制造J:=CONST(制造0);
食品量比:=CONST(399131$VOL/REF(MA(399131$VOL,5),1)*10);
食品C:=(399131$C); 食品H:=(399131$H); 食品L:=(399131$L); 食品O:=(399131$O);
食品涨跌:=CONST(((食品C-REF(食品C,1))/REF(食品C,1))*200);
食品偏差:=(2*食品C 食品H 食品L 食品O)/5-(MA(食品C,3) MA(食品C,6) MA(食品C,12) MA(食品C,24))/4;
食品R:=(食品偏差-LLV(食品偏差,N))/(HHV(食品偏差,N)-LLV(食品偏差,N))*10;
食品K:=SMA(食品R,M1,1); 食品D:=SMA(食品K,M2,1); 食品0:=3*食品K-2*食品D;
食品J:=CONST(食品0);
纺织量比:=CONST(399132$VOL/REF(MA(399132$VOL,5),1)*10);
纺织C:=(399132$C); 纺织H:=(399132$H); 纺织L:=(399132$L); 纺织O:=(399132$O);
纺织涨跌:=CONST(((纺织C-REF(纺织C,1))/REF(纺织C,1))*200);
纺织偏差:=(2*纺织C 纺织H 纺织L 纺织O)/5-(MA(纺织C,3) MA(纺织C,6) MA(纺织C,12) MA(纺织C,24))/4;
纺织R:=(纺织偏差-LLV(纺织偏差,N))/(HHV(纺织偏差,N)-LLV(纺织偏差,N))*10;
纺织K:=SMA(纺织R,M1,1); 纺织D:=SMA(纺织K,M2,1); 纺织0:=3*纺织K-2*纺织D;
纺织J:=CONST(纺织0);
创投量比:=CONST(399958$VOL/REF(MA(399958$VOL,5),1)*10);
创投C:=(399958$C); 创投H:=(399958$H); 创投L:=(399958$L); 创投O:=(399958$O);
创投涨跌:=CONST(((创投C-REF(创投C,1))/REF(创投C,1))*200);
创投偏差:=(2*创投C 创投H 创投L 创投O)/5-(MA(创投C,3) MA(创投C,6) MA(创投C,12) MA(创投C,24))/4;
创投R:=(创投偏差-LLV(创投偏差,N))/(HHV(创投偏差,N)-LLV(创投偏差,N))*10;
创投K:=SMA(创投R,M1,1); 创投D:=SMA(创投K,M2,1); 创投0:=3*创投K-2*创投D;
创投J:=CONST(创投0);
金融量比:=CONST(399190$VOL/REF(MA(399190$VOL,5),1)*10);
金融C:=(399190$C); 金融H:=(399190$H); 金融L:=(399190$L); 金融O:=(399190$O);
金融涨跌:=CONST(((金融C-REF(金融C,1))/REF(金融C,1))*200);
金融偏差:=(2*金融C 金融H 金融L 金融O)/5-(MA(金融C,3) MA(金融C,6) MA(金融C,12) MA(金融C,24))/4;
金融R:=(金融偏差-LLV(金融偏差,N))/(HHV(金融偏差,N)-LLV(金融偏差,N))*10;
金融K:=SMA(金融R,M1,1); 金融D:=SMA(金融K,M2,1); 金融0:=3*金融K-2*金融D;
金融J:=CONST(金融0);
石化量比:=CONST(399135$VOL/REF(MA(399135$VOL,5),1)*10);
石化C:=(399135$C); 石化H:=(399135$H); 石化L:=(399135$L); 石化O:=(399135$O);
石化涨跌:=CONST(((石化C-REF(石化C,1))/REF(石化C,1))*200);
石化偏差:=(2*石化C 石化H 石化L 石化O)/5-(MA(石化C,3) MA(石化C,6) MA(石化C,12) MA(石化C,24))/4;
石化R:=(石化偏差-LLV(石化偏差,N))/(HHV(石化偏差,N)-LLV(石化偏差,N))*10;
石化K:=SMA(石化R,M1,1); 石化D:=SMA(石化K,M2,1); 石化0:=3*石化K-2*石化D;
石化J:=CONST(石化0);
电子量比:=CONST(399136$VOL/REF(MA(399136$VOL,5),1)*10);
电子C:=(399136$C); 电子H:=(399136$H); 电子L:=(399136$L); 电子O:=(399136$O);
电子涨跌:=CONST(((电子C-REF(电子C,1))/REF(电子C,1))*200);
电子偏差:=(2*电子C 电子H 电子L 电子O)/5-(MA(电子C,3) MA(电子C,6) MA(电子C,12) MA(电子C,24))/4;
电子R:=(电子偏差-LLV(电子偏差,N))/(HHV(电子偏差,N)-LLV(电子偏差,N))*10;
电子K:=SMA(电子R,M1,1); 电子D:=SMA(电子K,M2,1);
电子0:=3*电子K-2*电子D;
电子J:=CONST(电子0);
金属量比:=CONST(399137$VOL/REF(MA(399137$VOL,5),1)*10);
金属C:=(399137$C); 金属H:=(399137$H); 金属L:=(399137$L); 金属O:=(399137$O);
金属涨跌:=CONST(((金属C-REF(金属C,1))/REF(金属C,1))*200);
金属偏差:=(2*金属C 金属H 金属L 金属O)/5-(MA(金属C,3) MA(金属C,6) MA(金属C,12) MA(金属C,24))/4;
金属R:=(金属偏差-LLV(金属偏差,N))/(HHV(金属偏差,N)-LLV(金属偏差,N))*10;
金属K:=SMA(金属R,M1,1); 金属D:=SMA(金属K,M2,1); 金属0:=3*金属K-2*金属D;
金属J:=CONST(金属0);
机械量比:=CONST(399138$VOL/REF(MA(399138$VOL,5),1)*10);
机械C:=(399138$C); 机械H:=(399138$H); 机械L:=(399138$L); 机械O:=(399138$O);
机械涨跌:=CONST(((机械C-REF(机械C,1))/REF(机械C,1))*200);
机械偏差:=(2*机械C 机械H 机械L 机械O)/5-(MA(机械C,3) MA(机械C,6) MA(机械C,12) MA(机械C,24))/4;
机械R:=(机械偏差-LLV(机械偏差,N))/(HHV(机械偏差,N)-LLV(机械偏差,N))*10;
机械K:=SMA(机械R,M1,1); 机械D:=SMA(机械K,M2,1); 机械0:=3*机械K-2*机械D;
机械J:=CONST(机械0);
医药量比:=CONST(399139$VOL/REF(MA(399139$VOL,5),1)*10);
医药C:=(399139$C); 医药H:=(399139$H); 医药L:=(399139$L); 医药O:=(399139$O);
医药涨跌:=CONST(((医药C-REF(医药C,1))/REF(医药C,1))*200);
医药偏差:=(2*医药C 医药H 医药L 医药O)/5-(MA(医药C,3) MA(医药C,6) MA(医药C,12) MA(医药C,24))/4;
医药R:=(医药偏差-LLV(医药偏差,N))/(HHV(医药偏差,N)-LLV(医药偏差,N))*10;
医药K:=SMA(医药R,M1,1); 医药D:=SMA(医药K,M2,1); 医药0:=3*医药K-2*医药D;
医药J:=CONST(医药0);
地产量比:=CONST(399200$VOL/REF(MA(399200$VOL,5),1)*10);
地产C:=(399200$C); 地产H:=(399200$H); 地产L:=(399200$L); 地产O:=(399200$O);
地产涨跌:=CONST(((地产C-REF(地产C,1))/REF(地产C,1))*200);
地产偏差:=(2*地产C 地产H 地产L 地产O)/5-(MA(地产C,3) MA(地产C,6) MA(地产C,12) MA(地产C,24))/4;
地产R:=(地产偏差-LLV(地产偏差,N))/(HHV(地产偏差,N)-LLV(地产偏差,N))*10;
地产K:=SMA(地产R,M1,1); 地产D:=SMA(地产K,M2,1); 地产0:=3*地产K-2*地产D;
地产J:=CONST(地产0);
服务量比:=CONST(399210$VOL/REF(MA(399210$VOL,5),1)*10);
服务C:=(399210$C); 服务H:=(399210$H); 服务L:=(399210$L); 服务O:=(399210$O);
服务涨跌:=CONST(((服务C-REF(服务C,1))/REF(服务C,1))*200);
服务偏差:=(2*服务C 服务H 服务L 服务O)/5-(MA(服务C,3) MA(服务C,6) MA(服务C,12) MA(服务C,24))/4;
服务R:=(服务偏差-LLV(服务偏差,N))/(HHV(服务偏差,N)-LLV(服务偏差,N))*10;
服务K:=SMA(服务R,M1,1); 服务D:=SMA(服务K,M2,1); 服务0:=3*服务K-2*服务D;
服务J:=CONST(服务0);
电力量比:=CONST(399140$VOL/REF(MA(399140$VOL,5),1)*10);
电力C:=(399140$C); 电力H:=(399140$H); 电力L:=(399140$L); 电力O:=(399140$O);
电力涨跌:=CONST(((电力C-REF(电力C,1))/REF(电力C,1))*200);
电力偏差:=(2*电力C 电力H 电力L 电力O)/5-(MA(电力C,3) MA(电力C,6) MA(电力C,12) MA(电力C,24))/4;
电力R:=(电力偏差-LLV(电力偏差,N))/(HHV(电力偏差,N)-LLV(电力偏差,N))*10;
电力K:=SMA(电力R,M1,1); 电力D:=SMA(电力K,M2,1); 电力0:=3*电力K-2*电力D;
电力J:=CONST(电力0);
建筑量比:=CONST(399150$VOL/REF(MA(399150$VOL,5),1)*10);
建筑C:=(399150$C); 建筑H:=(399150$H); 建筑L:=(399150$L); 建筑O:=(399150$O);
建筑涨跌:=CONST(((建筑C-REF(建筑C,1))/REF(建筑C,1))*200);
建筑偏差:=(2*建筑C 建筑H 建筑L 建筑O)/5-(MA(建筑C,3) MA(建筑C,6) MA(建筑C,12) MA(建筑C,24))/4;
建筑R:=(建筑偏差-LLV(建筑偏差,N))/(HHV(建筑偏差,N)-LLV(建筑偏差,N))*10;
建筑K:=SMA(建筑R,M1,1); 建筑D:=SMA(建筑K,M2,1); 建筑0:=3*建筑K-2*建筑D;
建筑J:=CONST(建筑0);
IT业量比:=CONST(399170$VOL/REF(MA(399170$VOL,5),1)*10);
IT业C:=(399170$C); IT业H:=(399170$H); IT业L:=(399170$L); IT业O:=(399170$O);
IT业涨跌:=CONST(((IT业C-REF(IT业C,1))/REF(IT业C,1))*200);
IT业偏差:=(2*IT业C IT业H IT业L IT业O)/5-(MA(IT业C,3) MA(IT业C,6) MA(IT业C,12) MA(IT业C,24))/4;
IT业R:=(IT业偏差-LLV(IT业偏差,N))/(HHV(IT业偏差,N)-LLV(IT业偏差,N))*10;
IT业K:=SMA(IT业R,M1,1); IT业D:=SMA(IT业K,M2,1); IT业0:=3*IT业K-2*IT业D;
IT业J:=CONST(IT业0);
批零量比:=CONST(399180$VOL/REF(MA(399180$VOL,5),1)*10);
批零C:=(399180$C); 批零H:=(399180$H); 批零L:=(399180$L); 批零O:=(399180$O);
批零涨跌:=CONST(((批零C-REF(批零C,1))/REF(批零C,1))*200);
批零偏差:=(2*批零C 批零H 批零L 批零O)/5-(MA(批零C,3) MA(批零C,6) MA(批零C,12) MA(批零C,24))/4;
批零R:=(批零偏差-LLV(批零偏差,N))/(HHV(批零偏差,N)-LLV(批零偏差,N))*10;
批零K:=SMA(批零R,M1,1); 批零D:=SMA(批零K,M2,1); 批零0:=3*批零K-2*批零D;
批零J:=CONST(批零0);
传播量比:=CONST(399220$VOL/REF(MA(399220$VOL,5),1)*10);
传播C:=(399220$C); 传播H:=(399220$H); 传播L:=(399220$L); 传播O:=(399220$O);
传播涨跌:=CONST(((传播C-REF(传播C,1))/REF(传播C,1))*200);
传播偏差:=(2*传播C 传播H 传播L 传播O)/5-(MA(传播C,3) MA(传播C,6) MA(传播C,12) MA(传播C,24))/4;
传播R:=(传播偏差-LLV(传播偏差,N))/(HHV(传播偏差,N)-LLV(传播偏差,N))*10;
传播K:=SMA(传播R,M1,1); 传播D:=SMA(传播K,M2,1); 传播0:=3*传播K-2*传播D;
传播J:=CONST(传播0);
流量比:=CONST(399160$VOL/REF(MA(399160$VOL,5),1)*10);
物流C:=(399160$C); 物流H:=(399160$H); 物流L:=(399160$L); 物流O:=(399160$O);
物流涨跌:=CONST(((物流C-REF(物流C,1))/REF(物流C,1))*200);
物流偏差:=(2*物流C 物流H 物流L 物流O)/5-(MA(物流C,3) MA(物流C,6) MA(物流C,12) MA(物流C,24))/4;
物流R:=(物流偏差-LLV(物流偏差,N))/(HHV(物流偏差,N)-LLV(物流偏差,N))*10;
物流K:=SMA(物流R,M1,1); 物流D:=SMA(物流K,M2,1); 物流0:=3*物流K-2*物流D;
物流J:=CONST(物流0);
军工量比:=CONST(399368$VOL/REF(MA(399368$VOL,5),1)*10);
军工C:=(399368$C); 军工H:=(399368$H); 军工L:=(399368$L); 军工O:=(399368$O);
军工涨跌:=CONST(((军工C-REF(军工C,1))/REF(军工C,1))*200);
军工偏差:=(2*军工C 军工H 军工L 军工O)/5-(MA(军工C,3) MA(军工C,6) MA(军工C,12) MA(军工C,24))/4;
军工R:=(军工偏差-LLV(军工偏差,N))/(HHV(军工偏差,N)-LLV(军工偏差,N))*10;
军工K:=SMA(军工R,M1,1); 军工D:=SMA(军工K,M2,1); 军工0:=3*军工K-2*军工D;
军工J:=CONST(军工0);
新能源量比:=CONST(399941$VOL/REF(MA(399941$VOL,5),1)*10);
新能C:=(399941$C); 新能H:=(399941$H); 新能L:=(399941$L); 新能O:=(399941$O);
能源涨跌:=CONST(((新能C-REF(新能C,1))/REF(新能C,1))*200);
新能偏差:=(2*新能C 新能H 新能L 新能O)/5-(MA(新能C,3) MA(新能C,6) MA(新能C,12) MA(新能C,24))/4;
新能R:=(新能偏差-LLV(新能偏差,N))/(HHV(新能偏差,N)-LLV(新能偏差,N))*10;
新能K:=SMA(新能R,M1,1); 新能D:=SMA(新能K,M2,1); 新能源0:=3*新能K-2*新能D;
新能源J:=CONST(新能源0);
板块涨跌X:=IF(CURR=2,食品涨跌,IF(CURR=5,建筑涨跌,IF(CURR=8,纺织涨跌,IF(CURR=11,物流涨跌,
IF(CURR=14,农林涨跌,IF(CURR=17,制造涨跌,IF(CURR=20,电子涨跌,IF(CURR=23,机械涨跌,
IF(CURR=26,医药涨跌,IF(CURR=29,金属涨跌,IF(CURR=32,石化涨跌,IF(CURR=35,地产涨跌,
IF(CURR=38,金融涨跌,IF(CURR=41,服务涨跌,IF(CURR=44,电力涨跌,IF(CURR=47,采掘涨跌,
IF(CURR=50,传播涨跌,IF(CURR=53,IT业涨跌,IF(CURR=56,军工涨跌,IF(CURR=59,新能源涨跌,
IF(CURR=62,创投涨跌,IF(CURR=65,批零涨跌,IF(CURR=68,大盘股涨跌,IF(CURR=71,中盘股涨跌,
IF(CURR=74,小盘股涨跌,DRAWNULL)))))))))))))))))))))))));
STICKLINE(1=1,板块涨跌X,0,12,0 ),COLOR990000;
STICKLINE(1=1,板块涨跌X,0,9.7,0 ),COLORCC0000;
STICKLINE(1=1,板块涨跌X,0,6.1,0 ),COLORFF4400;
STICKLINE(1=1,板块涨跌X,0,4.5,0 ),COLORFF8800;
STICKLINE(1=1,板块涨跌X,0,2.9,0 ),COLORFFCC00;
STICKLINE(1=1,板块涨跌X,0,1,0 ),COLORCYAN;
上证C:=(999999$C); 上证H:=(999999$H); 上证L:=(999999$L); 上证O:=(999999$O);
上证偏差:=(2*上证C 上证H 上证L 上证O)/5-(MA(上证C,3) MA(上证C,6) MA(上证C,12) MA(上证C,24))/4;
上证R:=(上证偏差-LLV(上证偏差,N))/(HHV(上证偏差,N)-LLV(上证偏差,N))*10;
上证K:=SMA(上证R,M1,1); 上证D:=SMA(上证K,M2,1);
上证J:3*上证K-2*上证D,COLORRED;
深证C:=(399001$C); 深证H:=(399001$H); 深证L:=(399001$L); 深证O:=(399001$O);
深证偏差:=(2*深证C 深证H 深证L 深证O)/5-(MA(深证C,3) MA(深证C,6) MA(深证C,12) MA(深证C,24))/4;
深证R:=(深证偏差-LLV(深证偏差,N))/(HHV(深证偏差,N)-LLV(深证偏差,N))*10;
深证K:=SMA(深证R,M1,1); 深证D:=SMA(深证K,M2,1);
深证J:3*深证K-2*深证D,COLOR00FF00;
个股偏差:=(2*C H L O)/5-(MA(C,3) MA(C,6) MA(C,12) MA(C,24))/4;
个股R:=(个股偏差-LLV(个股偏差,N))/(HHV(个股偏差,N)-LLV(个股偏差,N))*10;
个股K:=SMA(个股R,M1,1); 个股D:=SMA(个股K,M2,1);
个股J:3*个股K-2*个股D,COLOR110011,LINETHICK2;
板块J线X:=IF(CURR=2,食品J,IF(CURR=5,建筑J,IF(CURR=8,纺织J,IF(CURR=11,物流J,
IF(CURR=14,农林J,IF(CURR=17,制造J,IF(CURR=20,电子J,IF(CURR=23,机械J,
IF(CURR=26,医药J,IF(CURR=29,金属J,IF(CURR=32,石化J,IF(CURR=35,地产J,
IF(CURR=38,金融J,IF(CURR=41,服务J,IF(CURR=44,电力J,IF(CURR=47,采掘J,
IF(CURR=50,传播J,IF(CURR=53,IT业J,IF(CURR=56,军工J,IF(CURR=59,新能源J,
IF(CURR=62,创投J,IF(CURR=65,批零J,IF(CURR=68,大盘股J,IF(CURR=71,中盘股J,
IF(CURR=74,小盘股J,DRAWNULL)))))))))))))))))))))))));
STICKLINE(1=1,板块J线X,0,2.3,0 ),COLOR000055;
STICKLINE(1=1,板块J线X,0,1.7,0 ),COLOR000077;
STICKLINE(1=1,板块J线X,0,1.3,0 ),COLOR000099;
STICKLINE(1=1,板块J线X,0,0.9,0 ),COLOR0000BB;
STICKLINE(1=1,板块J线X,0,0.3,0 ),COLOR0000DD;
STICKLINE(1=1,板块J线X,0,0,0 ),COLOR0000FF;
板块量比X:=IF(CURR=1,食品量比,IF(CURR=4,建筑量比,IF(CURR=7,纺织量比,IF(CURR=10,物流量比,
IF(CURR=13,农林量比,IF(CURR=16,制造量比,IF(CURR=19,电子量比,IF(CURR=22,机械量比,
IF(CURR=25,医药量比,IF(CURR=28,金属量比,IF(CURR=31,石化量比,IF(CURR=34,地产量比,
IF(CURR=37,金融量比,IF(CURR=40,服务量比,IF(CURR=43,电力量比,IF(CURR=46,采掘量比,
IF(CURR=49,传播量比,IF(CURR=52,IT业量比,IF(CURR=55,军工量比,IF(CURR=58,新能源量比,
IF(CURR=61,创投量比,IF(CURR=64,批零量比,IF(CURR=67,大盘股量比,IF(CURR=70,中盘股量比,
IF(CURR=73,小盘股量比,DRAWNULL)))))))))))))))))))))))));
STICKLINE(1=1,板块量比X,0,2.3,0 ),COLOR555555;
STICKLINE(1=1,板块量比X,0,1.3,0 ),COLOR777777;
STICKLINE(1=1,板块量比X,0,1,0 ),COLOR999999;
STICKLINE(1=1,板块量比X,0,0.5,0 ),COLORBBBBBB;
STICKLINE(1=1,板块量比X,0,0.1,0 ),COLORdddDDD;
STICKLINE(1=1,板块量比X,0,0,0 ),COLORFFFFFF;
板块X:=IF(CURR=2,'食品',IF(CURR=5,'建筑',IF(CURR=8,'纺织',IF(CURR=11,'物流',IF(CURR=14,'农林',IF(CURR=17,'制造',
IF(CURR=20,'电子',IF(CURR=23,'机械',IF(CURR=26,'医药',IF(CURR=29,'金属',IF(CURR=32,'石化',IF(CURR=35,'地产',
IF(CURR=38,'金融',IF(CURR=41,'服务',IF(CURR=44,'电力',IF(CURR=47,'采掘',IF(CURR=50,'传播',IF(CURR=53,'IT业',
IF(CURR=56,'军工',IF(CURR=59,'新能源',IF(CURR=62,'创投',IF(CURR=65,'批零',IF(CURR=68,'大盘',
IF(CURR=71,'中盘',IF(CURR=74,'小盘',DRAWNULL)))))))))))))))))))))))));
DRAWTEXT(CURR=2 OR CURR=5 OR CURR=8 OR CURR=11 OR CURR=14 OR CURR=17 OR CURR=20 OR
CURR=23 OR CURR=26 OR CURR=29 OR CURR=32 OR CURR=35 OR CURR=38 OR CURR=41 OR CURR=44 OR
CURR=47 OR CURR=50 OR CURR=53 OR CURR=56 OR CURR=59 OR CURR=62 OR CURR=65 OR
CURR=68 OR CURR=71 OR CURR=74,(-4),板块X),COLORFFFFFF;
DRAWBAND(IF(CURR=8,上证J,DRAWNULL),rgb(250,2,2),上证J,RGB(250,2,2));
DRAWBAND(IF(CURR=8,深证J,DRAWNULL),RGB(0,250,2),深证J,RGB(0,250,2));
DRAWBAND(IF(CURR=8,个股J,DRAWNULL),RGB(25,2,25),个股J*0.99,RGB(25,2,25));
上证S:=IF(CURR=12,CONST(上证J),DRAWNULL);
STICKLINE(上证S,上证S,上证S,1,0),COLOR0000FF;
深证S:=IF(CURR=10,CONST(深证J),DRAWNULL);
STICKLINE(深证S,深证S,深证S,1,0),COLOR00FF00;
个股S:=IF(CURR=8,CONST(个股J),DRAWNULL);
STICKLINE(个股S,个股S,个股S,1,0),COLOR110011;
DRAWTEXT(CURR=12 OR CURR=10 OR CURR=8,IF(CURR=12,CONST(上证J),IF(CURR=10,CONST(深证J),
IF(CURR=8,CONST(个股J),DRAWNULL))),IF(CURR=12,'上证J',IF(CURR=10,'深证J',IF(CURR=8,'个股J',DRAWNULL)))),COLORFFFF00;
DRAWTEXT(CURR=55 OR CURR=20,IF(CURR=55,上证量比*1.05,IF(CURR=20,深证量比*1.05,DRAWNULL)),IF(CURR=55,'上证量比',IF(CURR=20,'深证量比',DRAWNULL))),COLORFFFFFF;
DRAWTEXT(IF(食品JCONST(REF(食品0,1)),CURR=2,DRAWNULL) OR IF(建筑JCONST(REF(建筑0,1)),CURR=5,DRAWNULL) OR
IF(纺织JCONST(REF(纺织0,1)),CURR=8,DRAWNULL) OR IF(物流JCONST(REF(物流0,1)),CURR=11,DRAWNULL) OR
IF(农林JCONST(REF(农林0,1)),CURR=14,DRAWNULL) OR IF(制造JCONST(REF(制造0,1)),CURR=17,DRAWNULL) OR
IF(电子JCONST(REF(电子0,1)),CURR=20,DRAWNULL) OR IF(机械JCONST(REF(机械0,1)),CURR=23,DRAWNULL) OR
IF(医药JCONST(REF(医药0,1)),CURR=26,DRAWNULL) OR IF(金属JCONST(REF(金属0,1)),CURR=29,DRAWNULL) OR
IF(石化JCONST(REF(石化0,1)),CURR=32,DRAWNULL) OR IF(地产JCONST(REF(地产0,1)),CURR=35,DRAWNULL),(-4),''),COLOR0000FF;
DRAWTEXT(IF(CONST(REF(金融0,1))=金融J,CURR=38,DRAWNULL) OR IF(CONST(REF(服务0,1))=服务J,CURR=41,DRAWNULL) OR
IF(CONST(REF(电力0,1))=电力J,CURR=44,DRAWNULL) OR IF(CONST(REF(采掘0,1))=采掘J,CURR=47,DRAWNULL) OR
IF(CONST(REF(传播0,1))=传播J,CURR=50,DRAWNULL) OR IF(CONST(REF(IT业0,1))=IT业J,CURR=53,DRAWNULL) OR
IF(CONST(REF(军工0,1))=军工J,CURR=56,DRAWNULL) OR IF(CONST(REF(新能源0,1))=新能源J,CURR=59,DRAWNULL) OR
IF(CONST(REF(创投0,1))=创投J,CURR=62,DRAWNULL) OR IF(CONST(REF(大盘股0,1))=大盘股J,CURR=65,DRAWNULL) OR
IF(CONST(REF(中盘股0,1))=中盘股J,CURR=68,DRAWNULL) OR IF(CONST(REF(批零0,1))=批零J,CURR=71,DRAWNULL) OR
IF(CONST(REF(小盘股0,1))=小盘股J,CURR=74,DRAWNULL),(-4),''),COLOR0000FF;
DRAWTEXT(CURR=83,8,'蓝柱 板块涨跌幅'),COLORFF0000;
DRAWTEXT(CURR=83,6,'红柱 板块J线'),COLOR0000FF;
DRAWTEXT(CURR=83,4,'银柱 板块量比'),COLORDDDDDD;



本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.denguang.com/rjsj/1c9a0381948cbd98724c3fb8.html

标签:

标签: