1. 首页
  2. 新股推荐

通达信股票公式之将军柱指标

通达信股票公式之将军柱指标

  将军柱指标

  aaa:=(3*C H L O)/6;

  VAR1:=(8*AAA 7*REF(AAA,1) 6*REF(AAA,2) 5*REF(AAA,3) 4*REF(AAA,4) 3*REF(AAA,5) 2*REF(AAA,6) REF(AAA,8))/36;

  VAr2:=(HHV(VAR1,5) HHV(VAR1,10) HHV(VAR1,20))/3;

  VAR3:=(LLV(VAR1,5) LLV(VAR1,10) LLV(VAR1,20))/3;

  VAR4:=(HHV(VAR2,5) HHV(VAR2,10) HHV(VAR2,20))/3;

  VAR5:=(LLV(VAR3,5) LLV(VAR3,10) LLV(VAR3,20))/3;

  VAR6:=(LLV(VAR1,2) LLV(VAR1,4) LLV(VAR1,6))/3;

  DRAWBAND(VAR1,rgb(155,50,50),VAR6,RGB(250,250,0));

  短线:VAR1,COLORWHITE;

  中线:VAR6,COLORYELLOW;

  下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;

  TJ1:=VOL》=HHV(VOL,3) AND VOL》2*REF(VOL,1) AND close》VAR1;

  将军柱:=FILTER(TJ1,5);

  TJ2:=IF(BARSLAst(将军柱)=1 AND CLOSE》REF(high,1),1,IF(BARSlast(将军柱)=2 AND CLOSE》REF(HIGH,2),1,IF(BARSLAST(将军柱)=3 AND CLOSE》REF(HIGH,3),1,0)));

  突破:TJ2=1;

  stiCKline(CLOSE,REF(HIGH,BARSLAST(将军柱)),REF(HIGH,BARSLAST(将军柱)),1,0),COLORCYAN;

  STICKLINE(CLOSE,REF(LOW,BARSLAST(将军柱)),REF(LOW,BARSLAST(将军柱)),1,0),COLORYELLOW;

  TJ3:=IF(BARSLAST(将军柱)=1 AND CLOSE》REF(LOW,1),1,IF(BARSLAST(将军柱)=2 AND CLOSE》REF(LOW,2),1,IF(BARSLAST(将军柱)=3 AND CLOSE》REF(LOW,3),1,0)));

  三天法则:=TJ3=1;

  成立:三天法则 AND 突破;

  条件成立:=FILTER(成立,3);

  DRAWTEXT(条件成立,L*0.99,将军柱),COLORYELLOW;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.denguang.com/xgtj/aecbcb9dc6a9935740bab91c.html

标签: