1. 首页
  2. 新股推荐

通信达公式破解 通达信分形主图公式源码

  DA1:=IF(130TotalbARSCOUNT,TOTalBARSCOUNT,130);

  DA:=IF(CUrrBARSCOUNtdA1,0,DA1);

  HI:=REFdate(HHV(H,DA),DATE);

  LO:=REfdaTE(LLV(L,DA),DATE);

  c1001:=IF(CURRBARSCOUNT=DA,C,DRAWNULL);

  GZ:=EXP(LN(HI/LO)/10);

  Lh1:=sum(IF(C1001=(HI/GZ),V,0),DA);

  Lh2:=SUM(IF(C1001=(HI/POW(GZ,2)) AND C1001(HI/GZ),V,0),DA);

  LH3:=SUM(IF(C1001=(HI/POW(GZ,3)) AND C1001(HI/POW(GZ,2)),V,0),DA);

  LH4:=SUM(IF(C1001=(HI/POW(GZ,4)) AND C1001(HI/POW(GZ,3)),V,0),DA);

  LH5:=SUM(IF(C1001=(HI/POW(GZ,5)) AND C1001(HI/POW(GZ,4)),V,0),DA);

  LH6:=SUM(IF(C1001=(HI/POW(GZ,6)) AND C1001(HI/POW(GZ,5)),V,0),DA);

  LH7:=SUM(IF(C1001=(HI/POW(GZ,7)) AND C1001(HI/POW(GZ,6)),V,0),DA);

  LH8:=SUM(IF(C1001=(HI/POW(GZ,8)) AND C1001(HI/POW(GZ,7)),V,0),DA);

  LH9:=SUM(IF(C1001=(LO*GZ) AND C1001

  LH10:=SUM(IF(C1001=LO AND C1001

  L1001:=REfdATE(HHV(LH1,DA),DATE),lineTHICK0;

  L2001:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;

  L3001:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;

  L4001:=REFDATE(HHV(LH4,DA),DATE);

  L5001:=REFDATE(HHV(LH5,DA),DATE);

  L6001:=REFDATE(HHV(LH6,DA),DATE);

  L7:=REFDATE(HHV(LH7,DA),DATE);

  L8:=REFDATE(HHV(LH8,DA),DATE);

  L9:=REFDATE(HHV(LH9,DA),DATE);

  L10:=REFDATE(HHV(LH10,DA),DATE);

  sss:=(L1001 L2001 L3001 L4001 L5001 L6001 L7 L8 L9 L10);

  VAR121:=zig(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)=REF(ZIG(3,6),3);

  VAR141:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)=REF(ZIG(3,22),3);

  VAR161:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)=REF(ZIG(3,51),3);

  VAR181:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)=REF(ZIG(3,72),3);

  卖:=(VAR121 VAR141 VAR161 VAR181),LINETHICK2;

  stICKLINE(CEILING(DA*L2001/SSS)*3=CURRBARSCOUNT AND BARSCOUNT(C)100 ,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR3c3C3A,LINETHICK3;

  stiCKLINE(CEILING(DA*L3001/SSS)*3=CURRBARSCOUNT AND BARSCOUNT(C)100 ,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR3C3C3A,LINETHICK3;

  STICKLINE(CEILING(DA*L4001/SSS)*3=CURRBARSCOUNT AND BARSCOUNT(C)100 ,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR3C3C3A,LINETHICK3;

  STICKLINE(CEILING(DA*L5001/SSS)*3=CURRBARSCOUNT AND BARSCOUNT(C)100 ,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR3C3C3A,LINETHICK3;

  STICKLINE(CEILING(DA*L6001/SSS)*3=CURRBARSCOUNT AND BARSCOUNT(C)100 ,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR3C3C3A,LINETHICK3;

  STICKLINE(CEILING(DA*L7/SSS)*3=CURRBARSCOUNT AND BARSCOUNT(C)100 ,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR3C3C3A,LINETHICK3;

  STICKLINE(CEILING(DA*L8/SSS)*3=CURRBARSCOUNT AND BARSCOUNT(C)100 ,LO*POW(GZ,2),LO*POW(GZ,3)*99/100,9,0)COLOR3C3C3A,LINETHICK3;

  STICKLINE(CEILING(DA*L9/SSS)*3=CURRBARSCOUNT AND BARSCOUNT(C)100 ,LO*POW(GZ,1),LO*POW(GZ,2)*99/100,9,0)COLOR3C3C3A,LINETHICK3;

  STICKLINE(CEILING(DA*L10/SSS)*3=CURRBARSCOUNT AND BARSCOUNT(C)100 ,LO,LO*POW(GZ,1)*99/100,9,0)COLOR3C3C3A,LINETHICK3;

  STICKLINE(CEILING(DA*L1001/SSS)*3=CURRBARSCOUNT AND BARSCOUNT(C)100,HI*99/100,HI/GZ,9,0)COLOR3C3C3A,LINETHICK3;

  DRAWKLINE(high,OPEN,LOW,close);

  上榜:=SIGNALS_USER(300, 0), NodRAW; {上榜金额1,则表示上榜了,这个是上榜总金额}

  净买入:=SIGNALS_USER(299, 0), NODRAW;

  DRAWicoN(上榜=1 AND 净买入=0 ,L*0.995,38);

  DRAWICON(上榜=1 AND 净买入0 ,L*0.995,39);

  NAME_299 := ↖ 龙;

  OUTTEXT_299:=VARCAT(VARCAT(NAME_299, ), VAr2STR(净买入, 0)), NODRAW;

  DRAWTEXT((上榜=1) ,-LOW*0.01 LOW,OUTTEXT_299),COLORLIRED;

  N:=(1,100,8);

  KK:=(0,2,0);

  TYP := (HIGH LOW CLOSE)/3;

  cci1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,6));

  CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));

  CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));

  CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));

  CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));

  CCI:=CCI1 CCI2 CCI3 CCI4 CCI5;

  aaaB:=(3*C H L O)/6;

  VVAR1:=(8*AAAB 7*REF(AAAB,1) 6*REF(AAAB,2) 5*REF(AAAB,3) 4*REF(AAAB,4) 3*REF(AAAB,5) 2*REF(AAAB,6) REF(AAAB,8))/36;

  VVAR6:=(LLV(VVAR1,2) LLV(VVAR1,4) LLV(VVAR1,6))/3;

  短线:IF(KK=0 , VVAR1, DRAWNULL),COLORWHITE;

  中线1:IF(KK=0 ,VVAR6, DRAWNULL),COLORYELLOW;

  DRAWBAND(短线,rgb(200,10,10),中线1,RGB(10,200,10));

  DRAWKLINE(H,O,L,C);

  下跌:IF(KK=0 AND VVAR1=VVAR6,VVAR6, DRAWNULL),COLORGREEN;

  中:=(MA(CLOSE,3) MA(CLOSE,6) MA(CLOSE,12) MA(CLOSE,24))/4;

  上轨:IF(KK=1,中 3*STD(中,10),DRAWNULL),COLOR000088,LINETHICK1;

  IF(KK=1,2*MA(上轨,12)-MA(C,21),DRAWNULL),COLOR666666;

  N1:=(1,100,10);

  n2:=(1,100,10);

  DIsp:=(1,3,2);

  K:=IF(PERIOD=5,1,{日}

  IF(PERIOD=6,1,{周}

  IF(PERIOD=7,1,{月}

  IF(PERIOD=8,1,{多分钟}

  IF(PERIOD=9,1,{多日}

  IF(PERIOD=10,1,{季}

  IF(PERIOD=11,2,{年}

  IF(PERIOD=4,1,{60F}

  IF(PERIOD=3,1,{30F}

  IF(PERIOD=2,1,{15F}

  IF(PERIOD=1,1{5F},1{1F})))))))))))/10;

  p1:=PEak(1,K*N1,1);

  P2:=peak(1,K*N1,2);

  WP1:=PEAKBARS(1,K*N1,1);

  WP2:=PEAKBARS(1,K*N1,2);

  t1:=TROUGH(2,K*N2,1);

  T2:=TROUGH(2,K*N2,2);

  WT1:=TROUGHBARS(2,K*N2,1);

  WT2:=TROUGHBARS(2,K*N2,2);

  TJ1:=P1T1 AND P2T2 ;

  ZD:=MAX(T1,T2);

  ZG:=MIN(P1,P2);

  LL:=MIN(T1,T2);

  HH:=MAX(P1,P2);

  TJ2:=FILTER(ZGZD,2);

  TJ3:=ZG=REF(ZG,BARSlast(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));

  TJ4:=TJ1TJ2NOT(TJ3);

  TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));

  TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));

  TJ7:=ZGREF(ZG,REF(BARSLAST(TJ4),1))ZD

  TJ8:=TJ4NOT(TJ5 OR TJ6 OR TJ7);

  Zsd:=IF(TJ8,ZD,DRAWNULL);

  Zsg:=IF(TJ8,ZG,DRAWNULL);

  zsH:=IF(TJ8,HH,DRAWNULL);

  ZSL:=IF(TJ8,LL,DRAWNULL);

  STICKLINE(TJ8,ZSH,ZSL,0,-1),COLORMAGENTA;

  STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),COLORMAGENTA;

  DRAWTEXT(DISP=2,ZSH,中枢),COLORWHITE;

  中枢高:PLOYLINE(DISP=2,REF(ZSD,BARSLAST(TJ8))),CIRCledOT,COLORLIRED;

  中枢低:PLOYLINE(DISP=2,REF(ZSG,BARSLAST(TJ8))),CIRCLEDOT,COLORLIGREEN;

  中枢最高:PLOYLINE(DISP=2,REF(ZSH,BARSLAST(TJ8))),POINTDOT,COLORRED;

  中枢最低:PLOYLINE(DISP=2,REF(ZSL,BARSLAST(TJ8))),POINTDOT,COLORGREEN;

  趋势高:PLOYLINE(DISP=3,ZIG(1,K*N1)),COLORLIBLUE;

  趋势低:PLOYLINE(DISP=3,ZIG(2,K*N2)),COLORLIBLUE;

  局部低点预选A:=BACKSET(LLV(L,5)

  局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);

  局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);

  局部高点预选A:=BACKSET(HHV(H,5)REF(HHV(H,4),1),4);

  局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);

  局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);

  缺口判断:=IF(LREF(H,1),1,IF(H

  距前高天:=BARSLAST(局部高点预选C=1);

  距前低天:=BARSLAST(局部低点预选C=-1);

  小值周期:=LOWRANGE(L);

  大值周期:=TOPRANGE(H);

  

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.denguang.com/xgtj/ca468dc5faf83d9e5141296e.html

标签:

标签:

标签: