1. 首页
  2. 股市资讯

「大智慧」黄金分割线主图指标公式

DRAWGBKLAST(v>1,stRIP(rgb(0,0,0),RGB(90,90,90),0));
ah:hhvall(h); al:llvall(l); {注意指标叠加该函数有循环或分支中将不准确,慎重使用叠加方式}
ahl:=ah-al;
a19:al ahl*0.191,coloraaaaaa;
a38:al ahl*0.382,color00aaaa;
a50:al ahl*0.500,lineTHICK1,POINtdOT,COLORGREEN;
a61:al ahl*0.618,color00aaaa;
a80:al ahl*0.809,coloraaaaaa;
{标注数字}y:=999;
DRAWTEXTREL(0,0,100% ah),coloraaaaaa;
DRAWTEXTREL(0,y*0.191,0.809% a80),coloraaaaaa;
DRAWTEXTREL(0,y*0.382,0.618% a61),color00aaaa;
DRAWTEXTREL(0,y*0.500,0.50% a50),color00aaaa;
DRAWTEXTREL(0,y*0.618,0.382% a38),color00aaaa;
DRAWTEXTREL(0,y*0.809,0.191% a19),coloraaaaaa;
DRAWTEXTREL(0,y-30,最高 ah),coloraaaaaa;
DRAWTEXTREL(900,0,100% ah),coloraaaaaa;
DRAWTEXTREL(900,y*0.191,0.809% a80),coloraaaaaa;
DRAWTEXTREL(900,y*0.382,0.618% a61),color00aaaa;
DRAWTEXTREL(900,y*0.500,0.50% a50),color00aaaa;
DRAWTEXTREL(900,y*0.618,0.382% a38),color00aaaa;
DRAWTEXTREL(900,y*0.809,0.191% a19),coloraaaaaa;
DRAWTEXTREL(900,y-30,最高 ah),coloraaaaaa;
{竖线}
W:=BARSlast(DISpsTATUS=1);
P:=BACKSET(DIspSTATUS=2,W/2 1);
VERTLINE(croSS(P,0.5),4),COLOR889999;
DRAWTEXTREL(500,0,最高 ),COLOrrED;
DRAWTEXTREL(500,900 76,最低),color00ff00;
DRAWTEXTREL(500,0.50*(900 76),0.5),color0099ff;
DRAWTEXTREL(500,0.191*(900 76),0.809),COLORYELLOW;
DRAWTEXTREL(500,0.382*(900 76),0.618),COLORYELLOW;
DRAWTEXTREL(500,0.618*(900 76),0.382),COLORYELLOW;
DRAWTEXTREL(500,0.809*(900 76),0.191),COLORYELLOW;
RSV:=(((close LLV(LOW,13)) / (HHV(high,13) LLV(LOW,13))) * 100);
K:=sma(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) (2 * D));
RSV24:=(((CLOSE LLV(LOW,55)) / (HHV(HIGH,55) LLV(LOW,55))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) (2 * D24));
压力位:=IF(CROSS(J24,J),HIGH,REF(HIGH,BARSLAST(CROSS(J24,J))));
支撑位:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24))));
{www.gainiangu.com 概念股网_大智慧股票指标公式}
TJ:=IF((C-REF(C,1))/REF(C,1)>0.025,1,0);
yl:=IF(C>REF(O,BARSLAST(TJ =1)),REF(O,BARSLAST(TJ =1)),0);
FT:=BARSLAST(yl);
YLX:=REF(yl,FT);
bt:=IF(Cref(OPEN,1),ref(C,1),0);
XFT:=BARSLAST(bt);
XYLX:=REF(bt,XFT);
平台调下:=CROSS(XYLX,C);
平台突破:=CROSS(C,YLX);
VAr2:=REF(LOW,1);
VAR3:=SMA(abs(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=ema(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=emA(IF(LOW<=VAR5,(VAR4 VAR6*2)/2,0),3)/618*VAR7;
主力进场:=VAR8>REF(VAR8,1);
进场:=ref(主力进场,1);
DRAWTEXT(进场 and 平台突破 ,L * 0.97,进),ALIGN1,COLOR0000FF;
DRAWTEXT(进场 and 平台突破 ,L * 0.94,场),ALIGN1,COLOR0000FF;
DRAWicoN(进场 and 平台突破 and L=支撑位,L* 0.93,1),ALIGN1,VALIGn2;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.denguang.com/zixun/0c6b3f47646d37b808fabea2.html