蜀ICP备16033882号-3

  1. 首页
  2. 股市资讯

「通达信」底部趋向 选股指标公式

N:=7;MM:=3;
MTR:=EXPMema(MAX(MAX(high-LOW,abs(HIGH-REF(close,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0LD>HD,LD,0),N);
pdi: DMP*100/MTR;
mdi: DMM*100/MTR;
adx: EXPMEMA(ABS(MDI-PDI)/(MDI PDI)*100,MM);
AdxR:EXPMEMA(ADX,MM);
XG:REF(PDI,1)<3.1 AND REF(ADX,1)>90 AND croSS(ADXR,ADX)
AND C/REF(C,1)>1.039 AND COUNT(C/REF(C,1)<0.956,6)>0,COLOrrED,NODRAW;
DRAWicoN(XG,20,25);
HH:=IF(CODELIKE(600),999999$H,399001$H);
OO:=IF(CODELIKE(600),999999$O,399001$O);
LL:=IF(CODELIKE(600),999999$L,399001$L);
CC:=IF(CODELIKE(600),999999$C,399001$C);
沪深大盘:IF(CODELIKE(600),999999$C,399001$C),COLORRED,NODRAW;
{DRAWKline(HH,OO,LL,CC);
M6V:MA(CC,6),COLORWHITE;
M21:MA(CC,21),COLORGREEN;
M62:MA(CC,62),COLOR0099FF;
M125:MA(CC,125),COLOR0099FF;}
d1:=YEAR AND MONTH AND DAY;
AA1:=strcat(COn2stR(YEAR,0),年);
AA2:=STRCAT(CON2STR(MONTH,0),月);
AA3:=STRCAT(CON2STR(DAY,0),日);
AA4:=STRCAT(【,IF(WEEKDAY=1,一,IF(WEEKDAY=2,二,IF(WEEKDAY=3,三,
IF(WEEKDAY=4,四,IF(WEEKDAY=5,五,IF(WEEKDAY=6,六,日)))))));
AA:=STRCAT(STRCAT(STRCAT(AA1,AA2),STRCAT(AA3,AA4)),】);
DRAWTEXT_FIX(D1,0,1,0,AA);
ZJS:=IF(CODELIKE(60) OR CODELIKE(999),999999$ADVANCE,399001$ADVANCE);
DJS:=IF(CODELIKE(60) OR CODELIKE(999),999999$INDExdEC,399001$INDEXDEC);
AA11:=STRCAT(STRCAT(STRCAT(〖,跌家数),〗),CON2STR(DJS,0));
AA22:=STRCAT(STRCAT(STRCAT(STRCAT(〖,涨家数),〗),CON2STR(ZJS,0)),AA11);
DRAWTEXT_FIX(D1,0.25,1,0,AA22),COLORGREEN;

{
选股公式:
N:=7;MM:=3;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0LD>HD,LD,0),N);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI PDI)*100,MM);
ADXR:=EXPMEMA(ADX,MM);
XG:REF(PDI,1)<3.1 AND REF(ADX,1)>90 AND CROSS(ADXR,ADX)
AND C/REF(C,1)>1.039 AND COUNT(C/REF(C,1)<0.956,6)>0,COLORRED;
}

本文来自投稿,不代表本人立场,如若转载,请注明出处:http://www.denguang.com/zixun/465df7ab3a50140f13976424.html

标签:

标签:

标签: