1. 首页
  2. 股市资讯

「通达信」超级好用的小树分时指标公式

DRAWGBK(C>0, rgb(40,120,20),RGB(00,00,00),0,0,1),lineTHICK2;
量:=VOL,VOLstICK;
五日量:MA(量,5),COLORWHITE;
Tt1:=BARSCOUNT(C);
均价黄:=sum(C*V,TT1)/SUM(V,TT1);
量两步:=MA(V,5)>REF(MA(V,5),1) AND REF(MA(V,5),1)>REF(MA(V,5),2);
价两步:= C>=REF(C,1) AND REF(C,1)>REF(C,2);
价上岗量破5:=C>均价黄 AND V>MA(V,5);
量起爆:=V>=REF(V,1)*2 ;
价创新高:=C>=HHV(C,0);
量创新高:=V>=HHV(V,0);
对昨日涨幅:=C/DYNAINfo(3)<=1.02;
每日一点:=量两步 AND 价两步 AND 价上岗量破5 AND 量起爆
AND 价创新高 AND 量创新高 AND 对昨日涨幅;
DRAWTEXT(每日一点,HHV(量,0)*0.9,起爆),COLORBLUE;
DRAWicoN(每日一点,HHV(量,0),1),COLOrrED;
stiCKLINE(每日一点,量,0,1,0),COLORMAGENTA;
DRAWTEXT(每日一点,量*0.9,),COLORRED;
DRAWTEXT(CURRBARSCOUNT=160,HHV(V,60)*0.9,
稳定),COLORGREEN;
{计算收益、已爆分钟}
VV01:=BARSSINCE(每日一点) 1;
首次起爆价:REF(C,VV01-1),NodRAW;
今天收益:(DYNAINFO(7)-首次起爆价)/首次起爆价*100,NODRAW;
流通盘0:CAPITal*100/100000000,NODRAW;
起爆时间:REF(TIME/10000,VV01),NODRAW;
已爆分钟:VV01-1,NODRAW;
{画出底线和红球}
首次起爆量:=REF(VOL,VV01-1);
DRAWICON(已爆分钟>=2,首次起爆量/2,13);{出现红球,至少已经确认2分钟了};
突破:REF(ema(C,14),1);
A1X:=(emA(C,10)-突破)/突破*100;
多方:=IF(A1X>=0,REF(EMA(C,10),BARSlast(croSS(A1X,0)) 1),DRAWNULL);
空方:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X)) 1),DRAWNULL);
STICKLINE(A1X>=0,多方,突破,10,0),COLOR000099;
STICKLINE(A1X<0,空方,突破,10,0),COLOR00Cc66;
今日开盘线:DYNAINFO(4),COLORMAGENTA;
今日最高价:DYNAINFO(5),COLORBLUE;
今日最低价:DYNAINFO(6),COLORGREEN;
今日均价线:DYNAINFO(11),COLORYELLOW;
DRAWTEXT(C=DYNAINFO(6) AND DYNAINFO(11)>=DYNAINFO(4)*1.01,C*1.002,买入),COLORWHITE;
DRAWTEXT(C=DYNAINFO(5) AND DYNAINFO(11)>=DYNAINFO(4)*1.01,C*0.998,卖出),COLORGREEN;
REflINE:-4,100;
VAR5:=LLV(LOW,75);
VAR6:=HHV(high,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=sma((close-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
主力线:100-(100-VARA),COLORWHITE,LINethICK2;
DRAWICON((CROSS(主力线,REF(主力线,1)) AND 主力线<=100),主力线,1);
DRAWICON((CROSS(主力线,REF(主力线,1)) AND 主力线>100),100*0.995,1);
持强:HHV(IF(TIME<=100000,COUNT(CROSS(主力线,REF(主力线,1)) CROSS(REF(主力线,1),主力线),0),0),0),COLORFfcC66,LINETHICK2;
连红:主力线>REF(主力线,1) AND 主力线>100;
(主力线,主力线<0),COLORRED,LINETHICK2;
(主力线,主力线>100),COLORGREEN,LINETHICK2;
(主力线,0,主力线<0,RGB(255,0,0));
(主力线,100,主力线>100,RGB(0,250,0));
100,POINtdOT,COLORGREEN,LINETHICK2;
50,POINTDOT,COLORGRAY,LINETHICK2;
趋势:SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),COLORYELLOW,LINETHICK2;
反趋势:=EMA((CLOSE-HHV(HIGH,25))/(LLV(LOW,25)-HHV(HIGH,25))*100,5);
顶线:100-(HHV(HIGH,25)-LLV(LOW,25))/EMA(HHV(HIGH,25)-CLOSE,5),COLORBLUE,LINETHICK2;
底线:(HHV(HIGH,25)-LLV(LOW,25))/EMA(CLOSE-LLV(LOW,25),5),COLORRED,LINETHICK2;
DRAWTEXT(底线>=趋势,趋势,★),COLORFF00FF;
DRAWTEXT(趋势<7,趋势,'★'),COLORYELLOW;
DRAWTEXT(趋势>=90 AND 趋势<=93,趋势,'★'),COLORGREEN;
DRAWTEXT(趋势>93,趋势,★),COLORBLUE;
DRAWTEXT(CROSS(趋势,底线),趋势,涨),COLORRED;
DRAWICON(CROSS(趋势,反趋势),趋势,1);
(趋势,趋势>=REF(趋势,1),RGB(255,0,0),趋势

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.denguang.com/zixun/5f7b6443cbfa2e11af3ecf4a.html