1. 首页
  2. 股市资讯

「通达信」麒麟黄金分割主图指标公式

N:=13;
VAR0:=(close*2 high LOW)/4*VOL;
VAR1:=sum(VAR0,89)/SUM(VOL,89);
搏杀生命线:IF(CLOSE>=VAR1,VAR1*1.001,VAR1*0.999),COLORFF80FF,lineTHICK1;
fl:MA(CLOSE,17) abs(MA(CLOSE,17)-REF(MA(CLOSE,17),1)),COLORF4E202;
FS:MA(CLOSE,17) MA(CLOSE,17)-REF(MA(CLOSE,17),1),COLORF4E202,LINethICK1;
CG:IF(MA(CLOSE,17)持股线:IF(CG=FS,CG,DRAWNULL),COLORYELLOW,LINETHICK1;
日最大涨幅:100*(H-REF(CLOSE,1))/REF(CLOSE,1),NodRAW,COLORYELLOW;
日涨幅:100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1),NODRAW,COLORWHITE;
日最大跌幅:100*(L-REF(CLOSE,1))/REF(CLOSE,1),NODRAW,COLORYELLOW;
实体幅:ABS(100*(CLOSE-OPEN)/OPEN),NODRAW,COLOrrED;
上影幅:IF(CLOSE>OPEN,100*(H-C)/C,100*(H-O)/O),NODRAW,COLORYELLOW;
下影幅:IF(CLOSE>OPEN,100*(O-L)/L,100*(C-L)/L),NODRAW,COLORWHITE;
N1:=10;
A:=HHV(HIGH,N1)=HIGH AND HIGH>REF(HIGH,1);A1:=FILTER(A,N1-1);
B:=LLV(LOW,N1)=LOW AND LOWts1:=BARSLAst(A1);
阻力位:REF(HIGH,TS1),COLORFFFFFF,LINETHICK0;
stiCKLINE(1,阻力位,阻力位,1,0),COLORFFFFFF;
TS11:=BARSlast(B1);
支撑位:REF(LOW,TS11),COLORFF8080, LINETHICK0;
STICKLINE(1,支撑位,支撑位,1,0),COLORFF8080;
HH:=HHV(HIGH,N);
LL:=LLV(LOW,N);
HH1:=BARSLAST((HH > REF(HH,1)));
LL1:=BARSLAST((LL < REF(LL,1)));
STICKLINE((Hh1 < LL1),CLOSE,OPEN,1,0),COLOR0000FF;
STICKLINE((HH1 > LL1),CLOSE,OPEN,1,0),COLORFF0000;
NN:=120;
高11:=REFdate(HHV(H,NN),DATE);
低11:=REfdaTE(LLV(L,NN),DATE);
H11:=低11 (高11-低11)*0.191;
H12:=低11 (高11-低11)*0.382;
h13:=低11 (高11-低11)*0.5;
H14:=低11 (高11-低11)*0.618;
H15:=低11 (高11-低11)*0.809;
DRAWTEXT(CURRBARSCOUNT=1,高11,高),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,H11,0.809),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,H12,0.618),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,H13,0.5),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,H14,0.382),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,H15,0.191),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,低11,低),COLORGREEN;
STICKLINE(CURRBARSCOUNT=13,高11,高11,100,-2),COLORGREEN,LINETHICK2;
STICKLINE(CURRBARSCOUNT=13,H11,H11,100,-1),COLORGREEN,LINETHICK2;
STICKLINE(CURRBARSCOUNT=13,H12,H12,100,-1),COLORGREEN,LINETHICK2;
STICKLINE(CURRBARSCOUNT=13,H13,H13,100,-1),COLORGREEN,LINETHICK2;
STICKLINE(CURRBARSCOUNT=13,H14,H14,100,-1),COLORGREEN,LINETHICK2;
STICKLINE(CURRBARSCOUNT=13,H15,H15,100,-1),COLORGREEN,LINETHICK2;
STICKLINE(CURRBARSCOUNT=13,低11,低11,100,-1),COLORGREEN,LINETHICK2;
DRAWTEXT_FIX(1,0.75,0,0,所属板块:),COLORLIGRAY;
DRAWTEXT_FIX(1,0.802,0,0,hyBLocK),COLORRED;
DRAWTEXT_FIX(1,0.85,0,0,DYblock),COLORRED;
DRAWTEXT_FIX(1,0.75,0.10,0,涨停价:),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.79,0.10,0,const(REF(C,1) (REF(C,1))/10)),COLORRED;
DRAWNUMBER(ISLASTBAR=1,CLOSE,CLOSE),COLORFFFFFF;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.denguang.com/zixun/7a71c38a269279ebb249b2e4.html