1. 首页
  2. 股市资讯

「通达信」另类黄金分割主图指标公式

T:=150;TT:=3;N1:=0;
AMOV:=VOL*(OPEN close)/2;
成本价:sum(AMOV,5)/SUM(VOL,5),lineTHICK1,COLOr209FFF;
MAA:MA(C,N1),COLOR00FF00;
DRAWTEXT(ISLASTBAR AND N1>0 AND MAA>REF(MAA,1),MAA,),COLOR00FF00;
DRAWTEXT(ISLASTBAR AND N1>0 AND MAA高1:=REF(HHV(H,T),TT);
低1:=REF(LLV(L,T),TT);
h1:=高1-(高1-低1)*0.191;
h2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFdate(高1,DATE),COLORFFFF00;
一:REfdaTE(H1,DATE),DOTLINE,COLORYELLOW;
二:REfdATE(H2,DATE),DOTLINE,COLORMAGENTA;
三:REFDATE(H3,DATE),COLOR00FFFF;
四:REFDATE(H4,DATE),DOTLINE,COLORMAGENTA;
五:REFDATE(H5,DATE),DOTLINE,COLORYELLOW;
低:REFDATE(低1,DATE),COLOR00FF00;
Tt3:=(CUrrBARSCOUNT=5);
TT4:=(CURRBARSCOUNT=5 3);
DRAWNUMBER(TT3 AND 顶,顶,顶),COLOR999900;
DRAWTEXT(TT4 AND 顶,顶,高:),COLOR208FFF;
DRAWNUMBER(TT3 AND 一,一,一),COLOR999999;
DRAWTEXT(TT4 AND 一,一,191:),COLOR208FFF;
DRAWNUMBER(TT3 AND 二,二,二),COLOR999999;
DRAWTEXT(TT4 AND 二,二,382:),COLOR208FFF;
DRAWNUMBER(TT3 AND 三,三,三),COLOR999999;
DRAWTEXT(TT4 AND 三,三,1/2:),COLOR208FFF;
DRAWNUMBER(TT3 AND 四,四,四),COLOR999999;
DRAWTEXT(TT4 AND 四,四,618:),COLOR208FFF;
DRAWNUMBER(TT3 AND 五,五,五),COLOR999999;
DRAWTEXT(TT4 AND 五,五,809:),COLOR208FFF;
DRAWNUMBER(TT3 AND 低,低*1.01,低),COLOR999900;
DRAWTEXT(TT4 AND 低,低*1.009,低:),COLOR208FFF;
AS:=(O H L C)/4;
BL:ema(AS,17),LINETHICK2,COLOR0000FF;
DRAWNUMBER(ISLAstBAR AND BL,BL*1.005,BL);
XGM:=croSS(C,BL);
DRAWicoN(XGM,BL,9);
IF(BL>REF(BL,1),BL,DRAWNULL),LINETHICK2,COLORYELLOW;
IF(BLDRAWTEXT(ISLASTBAR AND BL>REF(BL,1),BL,),COLOR00FFFF;
DRAWTEXT(ISlastBAR AND BL{概念股网-股票公式网站 www.gupAng.com}
DIFF:=EMA(CLOSE,12) EMA(CLOSE,26);
dea:=EMA(DIFF,9);
macD:=2*(DIFF-DEA),;
GMB:IF(CROSS(DIFF,DEA) AND DIFF>0,L*0.999,DRAWNULL),CROSsdOT,LINETHICK3,COLOR00FFFF;
GMC:IF(CROSS(DIFF,DEA) AND DIFF<0,L*0.999,DRAWNULL),CROSSDOT,LINETHICK3,COLOR208FFF;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF>0,L*0.998,金叉>0),COLORYELLOW;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF<0,L*0.998,'金叉<0'),COLORYELLOW;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=sma(RSV,3,1);
D:=SMA(K,3,1);
GJD:IF(CROSS(K,D) AND K>20 AND D<50,L*0.999,DRAWNULL),CROSSDOT,LINETHICK3,COLORFF00FF;
DRAWTEXT(CROSS(K,D) AND K>20 AND D<50,L*0.998,'K>20 D<50 KD金叉 '),COLOREEAaeE;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.denguang.com/zixun/8f83b1d0b23019a0ba8c5124.html

标签: