1. 首页
  2. 股市资讯

「通达信」日月同辉指标公式

日:80,COLORBLUE,lineTHICK4,POINtdOT;
月:20,COLORFF00FF,LINETHICK4,POINTDOT;
红:KD.K#WEEK(9,3,3),COLOrrED;
黄:KD.D#WEEK(9,3,3),COLORYELLOW;
KCD:=FILTER(croSS(红,黄) AND REF(黄,1)<30,13);
KCD1:=FILTER(CROSS(红,黄) AND REF(黄,1)>30,13);
DRAWicoN(KCd1,黄,23);
XG1:=KCD;
stICKLINE(XG1,20,10,4,0),COLOR000099;
stiCKLINE(XG1,20,10,2,0),COLOR0000BB;
STICKLINE(XG1,20,10,1,0),COLOR0000DD;
STICKLINE(XG1,0,20,0.3,0),COLOR0000FF;
DRAWTEXT(XG1,20,K买),COLOR0000FF;
SCD:=FILTER(CROSS(红,黄) AND REF(红,1)>78,13);
STICKLINE(SCD,90,80,4,0),COLOR009900;
STICKLINE(SCD,90,80,2,0),COLOR00BB00;
STICKLINE(SCD,90,80,1,0),COLOR00DD00;
STICKLINE(SCD,100,80,0.3,0),COLOR00FF00;
DRAWTEXT(SCD,95,K卖),COLOR00FF00;
DIFW:=macD.DIF#WEEK(12,26,9);
deaW:=macd.DEA#WEEK(12,26,9);
fca:=FILTER(CROSS(DIFW,DEAW) AND REF(DEAW,1)<0,13);
XG2:=fcA;
STICKLINE(XG2,10,20,4,0),COLOR990099;
STICKLINE(XG2,10,20,2,0),COLORBB00BB;
STICKLINE(XG2,10,20,1,0),COLORDD00DD;
STICKLINE(XG2,10,20,0.3,0),COLORFF00FF;
DRAWTEXT(XG2,10,M买),COLORFF00FF;
SCA:=FILTER(CROSS(DEAW,DIFW) AND REF(DIFW,1)>0,13);
STICKLINE(SCA,90,80,4,0),COLOR999900;
STICKLINE(SCA,90,80,2,0),COLORBBBB00;
STICKLINE(SCA,90,80,1,0),COLORdddD00;
STICKLINE(SCA,90,80,0.3,0),COLORFFFF00;
DRAWTEXT(SCA,83,M卖),COLORFFFF00;
STICKLINE(XG1 AND XG2,20,80,0.1,0 ),COLORFF00FF;
DRAWTEXT(XG1 AND XG2,50,K.M买),COLORRED;
DRAWTEXT(XG1 AND XG2,43,全仓),COLORRED;
STICKLINE(SCD AND SCA,20,80,0.1,0 ),COLOR00FF00;
DRAWTEXT(SCD AND SCA,50,K.M卖),COLORFF0000;
DIFF:=ema(close,12)-emA(CLOSE,26);
DEA:=EMA(DIFF,9);
TJ1:=DIFF>DEA;
SA1:=DIFFRSV:=(CLOSE-LLV(LOW,12))/(HHV(high,12)-LLV(LOW,12))*100;
K:=sma(RSV,3,1);
D:=SMA(K,3,1);
TJ2:=K>D;
SA2:=KLC:=REF(CLOSE,1);
rsi1:=(SMA(MAX(CLOSE-LC,0),9,1))/(SMA(abs(CLOSE-LC),9,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),26,1))/(SMA(ABS(CLOSE-LC),26,1))*100;
TJ3:=RSI1>RSI2;
SA3:=RSI1LWR1:=SMA(RSV,3,1);
LWr2:=SMA(LWR1,3,1);
TJ4:=LWR1>LWR2;
Sa4:=LWR1BBI:=(MA(CLOSE,3) MA(CLOSE,9) MA(CLOSE,12) MA(CLOSE,26))/4;
TJ5:=CLOSE>BBI;
SA5:=Cmtm:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,9),9)/EMA(EMA(ABS(MTM),9),3);
mmm:=100*EMA(EMA(MTM,26),12)/EMA(EMA(ABS(MTM),26),12);
TJ6:=MMS>MMM;
Sa6:=MMSTTJ:=TJ1 AND TJ2 AND TJ3 AND TJ4 AND TJ5 AND TJ6;
TTJ0:=FILTER(TTJ,13);
GOLD:=TTJ0;
STICKLINE(GOLD,20,30,4,0),COLOR009999;
STICKLINE(GOLD,20,30,2,0),COLOR00BBBB;
STICKLINE(GOLD,20,30,1,0),COLOR00DDDD;
STICKLINE(GOLD,10,30,0.3,0),COLOR00FFFF;
DRAWTEXT(GOLD,33,金指),COLOR00FFFF;
SAA:=SA1 AND SA2 AND SA3 AND SA4 AND SA5 AND SA6;
SAA0:=FILTER(SAA,13);
SAIL:=SAA0;
STICKLINE(SAIL,80,70,4,0),COLOR990000;
STICKLINE(SAIL,80,70,2,0),COLORBB0000;
STICKLINE(SAIL,80,70,1,0),COLORDD0000;
STICKLINE(SAIL,90,70,0.3,0),COLORFF0000;
DRAWTEXT(SAIL,75,指卖),COLORFF0000;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.denguang.com/zixun/df9a5276fd28f2e897d75157.html