1. 首页
  2. 股市资讯

「通达信」十全十美指标公式

N1:=3;n2:=5;N3:=9;n4:=13;N5:=21;N6:=34;
DIFF:=ema(close,N3)-emA(CLOSE,N4);
dea:=EMA(DIFF,N2);
DRAWICON(DIFF>DEA,1,1);
DRAWicoN(DIFF{DRAWText(ISLAstBAR=1,1,.macD),COLORFFFFFF;}
A1:=DIFF>DEA;
RSV1:=(CLOSE-Llv(LOW,N3))/(HHV(high,N3)-LLV(LOW,N3))*100;
K:=sma(RSV1,N1,1);
D:=SMA(K,N1,1);
DRAWICON(K>D,1.1,1);
DRAWICON(K{DRAWTEXT(ISlastBAR=1,1.1,.KDJ),COLORFFFFFF;}
A2:=K>D;
LC:=REF(CLOSE,1);
rsi1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(abs(CLOSE-LC),N2,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;
DRAWICON(RSI1>RSI2,1.2,1);
DRAWICON(RSI1{DRAWTEXT(ISLASTBAR=1,1.2,.RSI),COLORFFFFFF;}
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;
LWR1:=SMA(RSV,N1,1);
LWr2:=SMA(LWR1,N1,1);
DRAWICON(LWR1>LWR2,1.3,1);
DRAWICON(LWR1{DRAWTEXT(ISLASTBAR=1,1.3,.LWR),COLORFFFFFF;}
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,N1) MA(CLOSE,N2) MA(CLOSE,N3) MA(CLOSE,N4))/4;
DRAWICON(CLOSE>BBI,1.4,1);
DRAWICON(CLOSE{DRAWTEXT(ISLASTBAR=1,1.4,.BBI),COLORFFFFFF;}
A5:=CLOSE>BBI;
mtm:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);
mmm:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);
DRAWICON(MMS>MMM,1.5,1);
DRAWICON(MMS{DRAWTEXT(ISLASTBAR=1,1.5,.ZLMM),COLORFFFFFF;}
A6:=MMS>MMM;
BIAS:=(C-MA(C,N2))/MA(C,N2);
DIF:=(BIAS-REF(BIAS,16));
DBCD:=SMA(DIF,76,1);
MM:=MA(DBCD,5);
DRAWICON(DBCD>MM ,1.6,1);
DRAWICON(DBCD{DRAWTEXT(ISLASTBAR=1,1.6,.DBCD),COLORFFFFFF;}
A7:=DBCD>MM;
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE
-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),lineTHICK0,COLOrrED;
支撑:=LLV(持股,3),LINethICK0,COLOR00FFFF;
下跌:=MA(持股,12),COLOR6B8E23,LINETHICK0;
转向:=croSS(持股,下跌){ AND 下跌<30};
ma1:=MA(持股,5);
向下:=CROSS(MA1,持股) AND MA1>80;
DRAWICON(持股>下跌 ,1.7,1);
DRAWICON(持股<下跌,1.7,2);
{www.gainiangu.com 概念股网_最新股票指标公式}
{DRAWTEXT(ISLASTBAR=1,1.7,.Cgz),COLORFFFFFF;}
A8:=持股>下跌;
MT:=C-REF(C,1);
ZlgJ:=100*EMA(EMA(MT,N3),N3)/EMA(EMA(ABS(MT),N3),N3);
MazL:=MA(ZLGJ,5);
DRAWICON(ZLGJ>MAZL,1.8,1);
DRAWICON(ZLGJA9:=ZLGJ>MAZL;
{DRAWTEXT(ISLASTBAR=1,1.8,.ZLGJ),COLORFFFFFF;}
Pjj:=dma((HIGH LOW CLOSE*2)/4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE OPEN-LOW),IF(CLOSEhsL:=(xvL/20)/1.15;
攻击流量:=((HSL*0.55 (REF(HSL,1)*0.33)) (REF(HSL,2)*0.22));
GJJ:=EMA(攻击流量,8);
LljX:=EMA(攻击流量,3);
资金流量:=LLJX,LINETHICK0,COLOR0000FF;
DRAWICON(资金流量>0,1.95,1);
DRAWICON(资金流量<0,1.95,2);
A10:=资金流量>0;
{DRAWTEXT(ISLASTBAR=1,1.89,.ZJL),COLORFFFFFF;}
指导线:=(A1 A2 a3 a4 A5 a6 A7 A8 A9 a10),LINETHICK0,COLORFFFF00;
操作:IF(指导线 >6 ,1.1,1),LINETHICK3,COLORYELLOW;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.denguang.com/zixun/eb7801f80e67bdf243404e12.html

标签:

标签:

标签:

标签: