1. 首页
  2. 股市资讯

「通达信」解密主力主图指标公式

MA5:MA(C,5);
Ma6:=MA(C,6);
ma10:MA(C,10);
MA20:MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;mj1:=MA(J1,3);
Ma30:MA(C,30);
MA60:MA(C,60);
MA120:MA(C,120);
乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA20,MA30);
MAx2:=MAX(MAX1,MA60);
MIN1:=MIN(MA20,MA30);
MIn2:=MIN(MIN1,MA60);
K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
VAr2:=IF(K1<=8,1,0);
上火车轨:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND MA20-MA30>REF((MA20-MA30),1) ;
stICKline(上火车轨,MA20,MA30,0,0),COLOrrED;
手:=DRAWText(FILTER(上火车轨 AND macD.DIF<0.15 AND "MACD.DIF">REF(MACD.DIF,1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
( L<=MA20 AND C>MA20 OR (croSS(MA5,MA20)) ),5),L*0.98,神枪手);
神枪手选股:=FILTER(上火车轨 AND macd.DIF<0.15 AND "MACD.DIF">REF(MACD.DIF,1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5);{44.40240}
短线暴涨:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
AND MA(V,60)>REF(MA(V,60),1),5),MA60*0.99,短线暴涨),COLORRED;
DRAWTEXT(CROSS(KDJ.K(5,2,3),KDJ.D(5,2,3)) AND KDJ.D(5,2,3)<30 AND J1>MJ1 AND MA60>REF(MA60,1) AND COUNT(J1<1,3)>=1 ,L*0.995,买入),COLORYELLOW;
DRAWTEXT(CROSS(KDJ.D(5,2,3),KDJ.K(5,2,3)) AND KDJ.D(5,2,3)>65 AND J11,3)>=1,H*1.005,卖出),COLORGREEN;
DRAWTEXT(CROSS(KDJ.D(18,9,6),KDJ.K(18,9,6)) AND KDJ.D(18,9,6)>60 AND KDJ.J(45,15,15)>90,H*1.03,顶),COLORRED;
DRAWTEXT(CROSS(MA5,MA6) AND KDJ.K(5,3,3)>=50 AND KDJ.J(5,3,3)<31 ,L*0.92,'再买'),COLORMAGENTA;
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((close ema(CLOSE,21)) / emA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 20));
DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW 0.4),●买点);
DRAWTEXT((XL3 > 0),(LOW 0.2),●绝对底部);
X6:=REF(CLOSE,1);
X7:=((sma(MAX((CLOSE X6),0),7,1) / SMA(abs((CLOSE X6)),7,1)) * 100);
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
DRAWTEXT(X9,(high * 1.02),●出货),COLOR9000F5;
STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;
aaa:=const(HHV(H,90));
R1:=MA(CLOSE,1);
R2:=MA(CLOSE,3);
R3:=(MA(R2,1)*1);
R4:=(MA(R2,3)*1);
DRAWTEXT(CROSS(R3,R4),(LOW-0.1),进),COLORYELLOW;
LC:=REF(CLOSE,1);
rsi:=((SMA(MAX((CLOSE LC),0),3,1) / SMA(ABS((CLOSE LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),出),COLORGREEN;

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR12:=(HIGH LOW CLOSE)/3;
VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);
VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR18:=100-ABS(VAR17);
VAR19:=IF(VAR18<90,VAR18,100);
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16)) 60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,HIGH*1.02,大笔出货),LINethICK1,COLORFfcc66;
AA1:=AMOUNT/V;
BB1:=LCC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
Dd1:=LEE1:=V老鼠仓:=BB1 AND Cc1 AND DD1 AND EE1,LINETHICK0;
DRAWTEXT(老鼠仓,(LOW* 0.99),老鼠仓),COLOR40CCFF;

A74:=MA(CLOSE,20);
A75:=(CLOSE > MA(CLOSE,5));
A76:=(MA(CLOSE,5) > MA(CLOSE,10));
A77:=(CLOSE > MA(CLOSE,10));
A78:=(MA(CLOSE,5) > MA(CLOSE,20));
A79:=(CLOSE > MA(CLOSE,20));
A710:=REF(A74,1);
A711:=(A74 > A710);
avx:=(((((IF(A75,10,(0 10)) IF(A76,10,(0 10))) IF(A77,10,(0 10)))
IF(A78,10,(0 10))) IF(A79,10,(0 10))) IF(A711,10,(0 10)));
dsLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
t1:=COnsT(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
t3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));
T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));
T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));
T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));
T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));
T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));
T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));
T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));
T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));
{www.gainiangu.com 概念股网-通达信股票指标公式}
DRAWTEXT(T1=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,量能理想,明显走强,中线参与,仓位在2/3左右),COLORFF00FF ;
DRAWTEXT(T2=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,走势趋强,还显不足,短线进场,仓位在1/2左右),COLORFF00FF ;
DRAWTEXT(T3=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,量价良好,没有明显走强,短线进场,仓位1/2左右),COLORFF00FF ;
DRAWTEXT(T4=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右),COLORFF00FF ;
DRAWTEXT(T5=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,形态变坏,重仓者减持大半,清仓者观望),COLORFF00FF ;
DRAWTEXT(T6=1 AND CURRBARSCOUNT=70,AAA*0.98
,随大盘一起下跌,明显缩量走势,考虑到风险,减持或清仓),COLORFF00FF ;
DRAWTEXT(T7=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,该股放量下跌,走势明显偏弱,离场观望),COLORFF00FF ;
DRAWTEXT(T8=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,该股缩量下跌,走势偏弱,离场观望。),COLORFF00FF ;
DRAWTEXT(T9=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,该股形态良好,强势明显,量能充足,可以继续持有),COLORFF00FF ;
DRAWTEXT(T10=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,上行趋势不变,强势依然,量能开始转弱,注意风险),COLORFF00FF ;
DRAWTEXT(T11=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,该股仍然具备上涨潜力,但股性偏弱,可考虑减仓),COLORFF00FF ;
DRAWTEXT(T12=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,该股走势趋弱,量能不足,减持大部分筹码),COLORFF00FF ;
DRAWTEXT(T13=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,该股形态不佳,注意成交量的变化,目前不适合参与),COLORFF00FF ;
DRAWTEXT(T14=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,趋势不明,股价偏弱,注意量能变化,目前不宜参与),COLORFF00FF ;
DRAWTEXT(T15=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,有走强迹象,但量能不足,趋势不明,不适合操作),COLORFF00FF ;
DRAWTEXT(T16=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,该股走势太弱,没有参与价值。),COLORFF00FF ;
DRAWTEXT(T17=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,大盘理想,有明显走强迹象,中线参与,仓位在2/3左右),COLORFF00FF ;
DRAWTEXT(T18=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,如前期经过一轮下跌,最佳买点,前期有过一段涨幅需谨慎),COLORFF00FF ;
DRAWTEXT(T19=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,考虑短线进场,仓位在1/2左右,一旦量能放大,加仓买入),COLORFF00FF ;
DRAWTEXT(T20=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,大盘形态走坏,重仓者可以减去大部分仓位。),COLORFF0000 ;
DRAWTEXT(T21=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,大盘缩量调整,注意风险,短线清仓观望。),COLORFF0000 ;
DRAWTEXT(T22=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,大盘走势良好,量能理想,可以继续持有强势股。),COLORFF0000 ;
DRAWTEXT(T23=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,大盘形态良好,但量能稍显不足,随时准备减仓。),COLORFF0000 ;
DRAWTEXT(T24=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,大盘趋势不明,注意成交量变化,目前不适宜进场。),COLORFF0000 ;
DRAWTEXT(T25=1 AND CURRBARSCOUNT=70,AAA-(AAA*0.03)
,大盘趋势向下,量能萎缩,不适合进场。),COLORFF0000 ;
AA:=BARSCOUNT(C);
AH:=HHV(H,200);
al:=LLV(L,200);
A0:=(AH-AL)/40;
B1:=L-A0;
stiCKLINE((AA 0)/34=flOOR((AA 0)/34),B1,B1-1.5*A0,2,0),COLORF00FF0;
DRAWTEXT((AA 0)/34=FLOOR((AA 0)/34),B1-1*A0,时间窗,变盘),COLORF00FF0;
VAR2S:=(2*CLOSE HIGH LOW)/4;
VAR3S:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);
散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
庄家:=EMA(0.667*REF(散户,1) 0.333*散户,2)*VAR3S;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'吸'),COLORRED;
BBB1:=MA(C,1);
B2:=SMA(SMA(SMA(BBB1,2,1),2,1),2,1),COLORRED;
SMA2:=MA(B2,2);
VARB1:=(100 ((90 * (HHV(HIGH,21) CLOSE)) / (HHV(HIGH,21) LLV(LOW,21))));
VAR3:=(100 MA(((100 * (HHV(HIGH,6) CLOSE)) / (HHV(HIGH,6) LLV(LOW,6))),34));
买:DRAWTEXT(CROSS(VARB1,VAR3) AND B2>SMA2,(LOW * 0.97),⊙买),COLORRED;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.denguang.com/zixun/eda7ae4e921aca9dbb747a7c.html

标签:

标签:

股票配资
股票配资