1. 首页
  2. 股市资讯

「通达信」变色轨道主图指标公式

EXPMA5:EXPMA(C,5),COLORWHITE lineTHICK2;
EXPma13:EXPMA(C,13),COLORMAGENTA LINETHICK2;
牛熊分界线:dma(MA(close REF(CLOSE,5)/CLOSE*0.098,90),VOL),LINETHICK2,COLORYELLOW;
年线:DMA(MA(CLOSE REF(CLOSE,5)/CLOSE*0.098,250),VOL),COLORCYAN LINETHICK2;
CC:=abs((2*CLOSE high LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上轨:(1 7/100)*DD,CIRCledOT,COLORGREEN;
下轨:(1-7/100)*DD,CIRCLEDOT,COLORGREEN;
中轨:(上轨 下轨)/2,CIRCLEDOT,COLORGREEN;
上轨绿:IF(上轨>=REF(上轨,1),上轨,DRAWNULL),CIRCLEDOT,COLORGREEN,LINETHICK1;
上轨红:IF(上轨>=REF(上轨,1),上轨,DRAWNULL),CIRCLEDOT COLOrrED,LINETHICK1;
中轨绿:IF(中轨>=REF(中轨,1), 中轨,DRAWNULL),CIRCLEDOT,COLORGREEN,LINETHICK1;
中轨红:IF(中轨>=REF(中轨,1), 中轨,DRAWNULL),CIRCLEDOT COLORRED, LINETHICK1;
下轨绿:IF(下轨>=REF(下轨,1), 下轨,DRAWNULL),CIRCLEDOT,COLORGREEN,LINETHICK1;
下轨红:IF(下轨>=REF(下轨,1), 下轨,DRAWNULL),CIRCLEDOT COLORRED,LINETHICK1;
{以下这段源码可要可不要,主要是美化k线用}
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAr2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSEVARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAr11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
红色持股:=VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NodRAW;
离场:=IF(红色持股,LLV(C,2),DRAWNULL);
明离场价:=离场,COLORFF99FF,NODRAW;
今离场价:REF(离场,1)COLOR0000FF,NODRAW,COLORGREEN;
青色观望:=VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
进:=IF(青色观望,HHV(C,2),DRAWNULL);
明进场价:=进,COLOR33aacC,NODRAW,COLORCYAN;
今进场价:REF(明进场价,1),COLORFF0000,NODRAW,COLORRED;
短买:=VAR19,COLOR33AACC,NODRAW;
品红离场:=VAR1A,COLORFF99FF,NODRAW;
急速超跌:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
stICKLINE(CstiCKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
{www.gUPang.com 概念股网_最新股票指标公式}
STICKLINE(红色持股,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(红色持股,CLOSE,O,2,0),COLOR000088;
STICKLINE(红色持股,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(红色持股,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(青色观望,CLOSE,O,2.8,0),COLOR555500;
STICKLINE(青色观望,CLOSE,O,2,0),COLOR888800;
STICKLINE(青色观望,CLOSE,O,1.5,0),COLORaaaA00;
STICKLINE(青色观望,CLOSE,O,1,0),COLORcccC00;
STICKLINE(青色观望,CLOSE,O,0.5,0),COLOREEEE00;
CO:=(C-O);
STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(短买,O,O CO/3,2.8,0),COLOR335555;
STICKLINE(短买,O,O CO/3,2,0),COLOR338888;
STICKLINE(短买,O,O CO/3,1.5,0),COLOR33AAAA;
STICKLINE(短买,O,O CO/3,1,0),COLOR33cCCC;
STICKLINE(品红离场,O,O CO/3,2.8,0),COLOR550055;
STICKLINE(品红离场,O,O CO/3,2,0),COLOR880088;
STICKLINE(品红离场,O,O CO/3,1.5,0),COLORAA00AA;
STICKLINE(品红离场,O,O CO/3,1,0),COLORCC00CC;
STICKLINE(品红离场,O,O CO/3,0.5,0),COLOREE00EE;
WW:STICKLINE(ISlastBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF;
WW1:STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;
AA:DRAWTEXT(短买,REF(CLOSE,1)-0.2,↖买),COLORRED;
BB1:DRAWTEXT(品红离场,REF(CLOSE,1) 0.5,↙卖),COLORGREEN;

本文内容来自互联网转载,不代表本人立场,若侵犯您的权益,请联系我们第一时间删除,谢谢!如若转载,请注明出处:http://www.denguang.com/zixun/f367419bc93daff7d22c4359.html